misc/73833: smartctl -a /dev/da0 (any scsi disk fails)

Gót András andrej at antiszoc.hu
Thu Nov 11 12:20:32 PST 2004


>Number:         73833
>Category:       misc
>Synopsis:       smartctl -a /dev/da0 (any scsi disk fails)
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    freebsd-bugs
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Thu Nov 11 20:20:31 GMT 2004
>Closed-Date:
>Last-Modified:
>Originator:     Gót András
>Release:        5.3 RELEASE
>Organization:
>Environment:
FreeBSD linda.chello.hu 5.3-RELEASE FreeBSD 5.3-RELEASE #0: Fri Nov  5 04:19:18 UTC 2004     root at harlow.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC  i386

>Description:
I installed smartmontools package (ver: 5.32), from ports. It compiled without any errors as is remember. When I try to get smart data from my disk, i get the following:

smartctl -a /dev/da1
smartctl version 5.32 Copyright (C) 2002-4 Bruce Allen
Home page is http://smartmontools.sourceforge.net/

Device: WDIGTL   WD45 ULTRA2      Version: 1.00
(pass1:ahc0:0:1:0): MODE SENSE(06). CDB: 1a 0 1c 0 40 0
(pass1:ahc0:0:1:0): CAM Status: Command timeout
Serial number: WT7150055035
Device type: disk
(pass1:ahc0:0:1:0): MODE SENSE(06). CDB: 1a 0 19 0 40 0
(pass1:ahc0:0:1:0): CAM Status: SCSI Status Error
(pass1:ahc0:0:1:0): SCSI Status: Check Condition
(pass1:ahc0:0:1:0): UNIT ATTENTION csi:ff,ff,ff,ff asc:29,3
(pass1:ahc0:0:1:0): Bus device reset function occurred
Local Time is: Thu Nov 11 21:07:09 2004 CET
Device does not support SMART
(pass1:ahc0:0:1:0): LOG SENSE. CDB: 4d 0 40 0 0 0 0 0 c 0
(pass1:ahc0:0:1:0): CAM Status: Command timeout

Of course this worked before with the same disk, but not with the same scsi card. I used the integrated AHA-7880 UW, now the PCI AHA-2940U2W (7980). The card and disk is working perfectly. I tried both the LVD and SE channel, the result is the same.

I don't really whether it's a kernel driver problem or a sw bug in smartmontool or maybe both.

relevant dmesg:
<<<<<<<<<<<<<<<<< Dump Card State Ends >>>>>>>>>>>>>>>>>>
(pass1:ahc0:0:1:0): SCB 0xa - timed out
sg[0] - Addr 0x133338f5 : Length 64
(pass1:ahc0:0:1:0): Queuing a BDR SCB
(pass1:ahc0:0:1:0): Bus Device Reset Message Sent
ahc0: Timedout SCBs already complete. Interrupts may not be functioning.
(pass1:ahc0:0:1:0): no longer in timeout, status = 24b
ahc0: Bus Device Reset on A:1. 1 SCBs aborted
ahc0: Recovery Initiated
>How-To-Repeat:
      
>Fix:
    
>Release-Note:
>Audit-Trail:
>Unformatted:
 >>>>>>>>>>>>>>>>>> Dump Card State Begins <<<<<<<<<<<<<<<<<
 ahc0: Dumping Card State while idle, at SEQADDR 0x8
 Card was paused
 ACCUM = 0x4, SINDEX = 0x64, DINDEX = 0x65, ARG_2 = 0xe
 HCNT = 0x0 SCBPTR = 0xc
 SCSISIGI[0x0] ERROR[0x0] SCSIBUSL[0x0] LASTPHASE[0x1]:(P_BUSFREE)
 SCSISEQ[0x12]:(ENAUTOATNP|ENRSELI) SBLKCTL[0xa]:(SELWIDE|SELBUSB)
 SCSIRATE[0x0] SEQCTL[0x10]:(FASTMODE) SEQ_FLAGS[0xc0]:(NO_CDB_SENT|NOT_IDENTIFIED)
 SSTAT0[0x0] SSTAT1[0xa]:(PHASECHG|BUSFREE) SSTAT2[0x0]
 SSTAT3[0x0] SIMODE0[0x8]:(ENSWRAP) SIMODE1[0xa4]:(ENSCSIPERR|ENSCSIRST|ENSELTIMO)
 SXFRCTL0[0x80]:(DFON) DFCNTRL[0x0] DFSTATUS[0x89]:(FIFOEMP|HDONE|PRELOAD_AVAIL)
 STACK: 0xe5 0x167 0x17d 0x3
 SCB count = 130
 Kernel NEXTQSCB = 128
 Card NEXTQSCB = 128
 QINFIFO entries:
 Waiting Queue entries:
 Disconnected Queue entries: 12:58
 
 I hoped it helped, of course I can post any further information/data if needed.
 


More information about the freebsd-bugs mailing list