[Bug 207317] www/apache22 missing some modules [2016Q1 branch]

bugzilla-noreply at freebsd.org bugzilla-noreply at freebsd.org
Thu Feb 18 22:30:16 UTC 2016


            Bug ID: 207317
           Summary: www/apache22 missing some modules [2016Q1 branch]
           Product: Ports & Packages
           Version: Latest
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: Individual Port(s)
          Assignee: apache at FreeBSD.org
          Reporter: florian.heigl at gmail.com
          Assignee: apache at FreeBSD.org
             Flags: maintainer-feedback?(apache at FreeBSD.org)

After upgrading one test system I noticed a failure in apache22.

# service apache22 start               
Performing sanity check on apache22 configuration:
httpd: Syntax error on line 72 of /usr/local/etc/apache22/httpd.conf: Cannot
load /usr/local/libexec/apache22/mod_proxy.so into server: Cannot open
Starting apache22.

At first I thought this was modules having become part of apache core, but no.
I tried removing the LoadModule lines and it'll throw an error for ProxyPass
directive, so the functionality really isn't there.

This is the modules I still see:
ls -m /usr/local/libexec/apache22
httpd.exp, mod_actions.so*, mod_alias.so*, mod_asis.so*, mod_auth_basic.so*,
mod_auth_digest.so*, mod_authn_alias.so*,
mod_authn_anon.so*, mod_authn_dbm.so*, mod_authn_default.so*,
mod_authn_file.so*, mod_authz_dbm.so*, mod_authz_default.so*,
mod_authz_groupfile.so*, mod_authz_host.so*, mod_authz_owner.so*,
mod_authz_user.so*, mod_autoindex.so*, mod_cache.so*,
mod_cern_meta.so*, mod_cgi.so*, mod_charset_lite.so*, mod_dav.so*,
mod_dav_fs.so*, mod_deflate.so*, mod_dir.so*,
mod_disk_cache.so*, mod_dumpio.so*, mod_env.so*, mod_expires.so*,
mod_file_cache.so*, mod_filter.so*, mod_headers.so*,
mod_imagemap.so*, mod_include.so*, mod_info.so*, mod_log_config.so*,
mod_logio.so*, mod_mime.so*, mod_mime_magic.so*,
mod_negotiation.so*, mod_reqtimeout.so*, mod_rewrite.so*, mod_setenvif.so*,
mod_speling.so*, mod_ssl.so*, mod_status.so*,
mod_unique_id.so*, mod_userdir.so*, mod_usertrack.so*, mod_version.so*,

So it seems to be very related to the proxy module only.
I tried installing mod_proxy_html but that is just an addon and will not make a

I guess this is related to following change:
  AFFECTS: users of www/apache22, www/apache22-event-mpm, www/apache22-itk-mpm,
www/apache22-peruser-mpm, www/apache22-worker-mpm
  AUTHOR: ohauer at FreeBSD.org

  The port use now the options NG framework, this means WITH_xxx
  directives are no longer valid.

  - APR only specific options like THREADS, MYSQL, PGSQL, SQLITE,
    BDB and IPV6 where removed.
  - PKGNAME has changed from apache-2... to apache22-2...
  - PROXY is now a MULTI directive which means at last one additional

I've selected all of those, yet a pkg rquery shows the following:

PROXY off off (null)
PROXY_AJP off off (null)
PROXY_BALANCER off off (null)
PROXY_CONNECT off off (null)
PROXY_FTP off off (null)
PROXY_HTTP off off (null)
PROXY_SCGI off off (null)

(same for the pkgs.freebsd.org package installed locally)

I can say that both the pkgs.freebsd.org package and the one from my own
poudriere have this issue, and i re-ran a build after saving back the port

Please could someone check into this? It *might* be poudriere related but I'm
not sure of that.

1) is the option enabled in your build
2) is there a makefile hickup that makes it not take effect

You are receiving this mail because:
You are the assignee for the bug.

More information about the freebsd-apache mailing list