maintainer-feedback requested: [Bug 207317] www/apache22 missing some modules [2016Q1 branch]

bugzilla-noreply at bugzilla-noreply at
Thu Feb 18 22:30:16 UTC 2016

florian.heigl at has reassigned Bugzilla Automation
<bugzilla at>'s request for maintainer-feedback to apache at
Bug 207317: www/apache22 missing some modules [2016Q1 branch]

--- Description ---
After upgrading one test system I noticed a failure in apache22.

# service apache22 start	       
Performing sanity check on apache22 configuration:
httpd: Syntax error on line 72 of /usr/local/etc/apache22/httpd.conf: Cannot
load /usr/local/libexec/apache22/ into server: Cannot open
Starting apache22.

At first I thought this was modules having become part of apache core, but no.
I tried removing the LoadModule lines and it'll throw an error for ProxyPass
directive, so the functionality really isn't there.

This is the modules I still see:
ls -m /usr/local/libexec/apache22

So it seems to be very related to the proxy module only.
I tried installing mod_proxy_html but that is just an addon and will not make a

I guess this is related to following change:
  AFFECTS: users of www/apache22, www/apache22-event-mpm, www/apache22-itk-mpm,
www/apache22-peruser-mpm, www/apache22-worker-mpm
  AUTHOR: ohauer at

  The port use now the options NG framework, this means WITH_xxx
  directives are no longer valid.

  - APR only specific options like THREADS, MYSQL, PGSQL, SQLITE,
    BDB and IPV6 where removed.
  - PKGNAME has changed from apache-2... to apache22-2...
  - PROXY is now a MULTI directive which means at last one additional

I've selected all of those, yet a pkg rquery shows the following:

PROXY off off (null)
PROXY_AJP off off (null)
PROXY_BALANCER off off (null)
PROXY_CONNECT off off (null)
PROXY_FTP off off (null)
PROXY_HTTP off off (null)
PROXY_SCGI off off (null)

(same for the package installed locally)

I can say that both the package and the one from my own
poudriere have this issue, and i re-ran a build after saving back the port

Please could someone check into this? It *might* be poudriere related but I'm
not sure of that.

1) is the option enabled in your build
2) is there a makefile hickup that makes it not take effect

More information about the freebsd-apache mailing list