Turion 64x2 still hanging after C1E patch

Peter Jeremy peterjeremy at optushome.com.au
Sat May 5 10:36:58 UTC 2007

On 2007-May-03 20:26:24 +0800, Ariff Abdullah <ariff at FreeBSD.org> wrote:
>This probably something else. Try disabling sio, ppc through
>/boot/device.hints. Several HP laptops are known to hang because of

I removed ppc from the kernel.  Disabling sio{0,1} seems to have
fixed the problem.  That's a PITA because it means I can't use IrDA.

>> I've re-applied idlecpu_apic_5.diff and it seems to work with
>> hw.apic.idle_cpu="1" (but see below).  I've hacked local_apic.c
>> to save the value read from MSR_C001_0055 and that shows that
>> C1eOnCmpHalt is set.
>This is expected, and the recent "fix" is supposed to overwrite and
>disable C1E on each core/cpu.

My comment was intended to indicate that the C1E fix code was being

>> Worse,I've noticed that the RTC interrupt occasionally stops.  I
>> have worked out that I can restart it by writing to sysctl
>> machdep.adjkerntz (which was the easiest way to issue
>> rtcin(RTC_INTR) from userland). I presume that occasionally the RTC
>> interrupt is lost and so never reset (as per the comment above
>> rtcintr()).
>> I haven't yet tried using the i8254 as a wakeup source.
>> Any ideas on where to look next?
>Show us your processor Id from dmesg.

CPU: AMD Turion(tm) 64 X2 Mobile Technology TL-50 (1607.33-MHz K8-class CPU)
  Origin = "AuthenticAMD"  Id = 0x40f82  Stepping = 2
  AMD Features=0xea500800<SYSCALL,NX,MMX+,FFXSR,RDTSCP,LM,3DNow!+,3DNow!>
  AMD Features2=0x1f<LAHF,CMP,SVM,ExtAPIC,CR8>
  Cores per package: 2

After disabling sio, I don't need hw.apic.idle_cpu - which removes the
RTC interrupt anyway.

Peter Jeremy
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-amd64/attachments/20070505/b28b5804/attachment.pgp

More information about the freebsd-amd64 mailing list