Turion 64x2 still hanging after C1E patch

Ariff Abdullah ariff at FreeBSD.org
Thu May 3 12:26:28 UTC 2007

On Thu, 3 May 2007 21:42:39 +1000
Peter Jeremy <peterjeremy at optushome.com.au> wrote:
> On 2007-Apr-26 10:15:25 +0800, Ariff Abdullah <ariff at freebsd.org>
> wrote:
> >On Wed, 25 Apr 2007 16:59:51 -0700
> >Maxim Sobolev <sobomax at FreeBSD.org> wrote:
> >> Ariff Abdullah wrote:
> >> > ariff       2007-04-25 19:58:42 UTC
> >> >   Disable C1 Enhanced mode on AMD K8 Family Revision F and
> >above > >   to keep local APIC timer alive.
> ...
> >> Is it expected to fix some Turion laptops out there, that were 
> >> previously unable to run in the SMP mode due to LAPIC timer on
> >one > core  being down on boot up?
> >
> >Certainly yes.
> My HP/Compaq V6107 still goes into a coma even with this patch.  If
> I boot to single-user mode, it seems to happen immediately after the
> CD-ROM probe messages (which would be when the system becomes idle).
> Otherwise, it goes comatose whilst trying to load the entropy.
This probably something else. Try disabling sio, ppc through
/boot/device.hints. Several HP laptops are known to hang because of

> I've re-applied idlecpu_apic_5.diff and it seems to work with
> hw.apic.idle_cpu="1" (but see below).  I've hacked local_apic.c
> to save the value read from MSR_C001_0055 and that shows that
> C1eOnCmpHalt is set.
This is expected, and the recent "fix" is supposed to overwrite and
disable C1E on each core/cpu.

> Worse,I've noticed that the RTC interrupt occasionally stops.  I
> have worked out that I can restart it by writing to sysctl
> machdep.adjkerntz (which was the easiest way to issue
> rtcin(RTC_INTR) from userland). I presume that occasionally the RTC
> interrupt is lost and so never reset (as per the comment above
> rtcintr()).
> I haven't yet tried using the i8254 as a wakeup source.
> Any ideas on where to look next?

Show us your processor Id from dmesg.

Ariff Abdullah

... Recording in stereo is obviously too advanced
    and confusing for us idiot ***** users :P ........
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-amd64/attachments/20070503/33c8fad8/attachment.pgp

More information about the freebsd-amd64 mailing list