java/jdk15: build failure on FBSD 6.0/AMD64

O. Hartmann ohartman at
Wed Sep 14 16:15:08 PDT 2005

Guy Helmer wrote:
> O. Hartmann wrote:
>> Hello.
>> Since my last posting about failing to build a working JDK I tried 
>> again with all the recommendations I got from this list.
>> On FreeBSD/i386, build process still dies due to a sanity check error 
>> (watch out my previous posting about this error). One possible cause 
>> should be a missing Linuxulator - but that's not the trueth. Linux was 
>> enabled either as kernel module and loaded when system boots or 
>> staticaly built into the kernel. In both cases I receive the same 
>> error :-(
> But was linprocfs mounted as /compat/linux/proc?

Yes, it was, I explicitely checked this.

>> On FreeBSD/AMD64 everything seems to build perfectly since this error 
>> occurs (and it seemes to be at the end of the build process):
>> Force the Client VM when dumping the shared archive since you can't
>> dump the archive with the Server VM.
> I applied Greg Lewis' jdk15 patch he sent yesterday (at 
> to the java/jdk15 port and I've successfully built the port on amd64 
> with it today.  I tried building and installing it earlier today before 
> I applied the patch, and it failed during the install with the "can't 
> dump" error...

All right, this sounds to me to take a further shot. Maybe JDK is on 
FBSD 6/AMD64 to new and just a 'job in progress'. I will try it again.

>> I feel confused, I read about this error but no solutions or 
>> workaround. It confuses me a bit that I still run into harsh trouble 
>> although I do exactly all the steps the port repository recommends! On 
>> the other hand, I ran into trouble fetching some essential ports 
>> needed by the jdk15-build process on an AMD64 architecture, but they 
>> are i386 and I needed fetching them on another i386-based machine (I 
>> remember myself it was a XFree86 library for Linux and not available 
>> for amd64, but fetching ports from FreeBSD 6.0/amd64 let me get ports 
>> only for amd64!).
> IIRC, I was able to fetch and install all the amd64 packages for Linux 
> compatibility on my new amd64 machine installed from 6.0BETA2, and the 
> Linux JDK worked just fine for me...  I used portinstall, and I 
> explicitly set PACKAGESITE to retrieve the binary packages from 

I just fetch the ports collection via cvsup and its brothers and 
sisters. On amd64-based hosts I very often see a set ARCH-variable and 
errors not being capable fetching tarballs due to be i386-tarballs. This 
seems to be especially for Linux files, where some '' type 
files are looked for.

>> Within the last 4 years I belong to the 'small' (?) group of FreeBSD 
>> users who never had success compiling a working JAVA environment. So 
>> neither OpenOffice is fully working, nor FireFox or Mozilla are 
>> capable of working with JAVA under FBSD 5/6. Mmmmmmhhhh ...

I will try it again on i386 and amd64. Hope it will work then ...

Thank you for your answer,

More information about the freebsd-amd64 mailing list