Truss & finding a working tracer

David S. Besade webmaster at
Sun Oct 30 13:11:10 PST 2005

I had some help in getting truss to work. Thanks for all the help guys.


> From: Roland Smith <rsmith at>
> Date: Sun, 30 Oct 2005 22:05:42 +0100
> To: "David S. Besade" <webmaster at>
> Cc: <freebsd-amd64 at>
> Subject: Re: Truss & finding a working tracer
> On Sun, Oct 30, 2005 at 01:01:50PM -0600, David S. Besade wrote:
>> Hey guys
>> I am trying to trace an application for another list to get it working but I
>> am running into the following issues:
>> tried to build ltrace but found out its only for i386 machines, mine is
>> AMD64 Based (Nocona Cored Xeons) so it would build. I found out the same
>> with strace.
> Have you tried ktrace? It's part of the base system. I've found it very
> usefull.
>> Now I have truss but alas its not working properly yet I keep getting errors
>> like this:
>> s3# truss /bin/echo hello
>> truss: cannot open /proc/39477/mem: No such file or directory
>> truss: cannot open /proc/curproc/mem: No such file or directory
>> s3# 
> Is the /proc filesystem mounted?
> Roland
> -- 
> R.F.Smith ( Please send e-mail as plain text.
> public key:

More information about the freebsd-amd64 mailing list