Truss & finding a working tracer

Roland Smith rsmith at
Sun Oct 30 13:05:47 PST 2005

On Sun, Oct 30, 2005 at 01:01:50PM -0600, David S. Besade wrote:
> Hey guys
> I am trying to trace an application for another list to get it working but I
> am running into the following issues:
> tried to build ltrace but found out its only for i386 machines, mine is
> AMD64 Based (Nocona Cored Xeons) so it would build. I found out the same
> with strace.

Have you tried ktrace? It's part of the base system. I've found it very

> Now I have truss but alas its not working properly yet I keep getting errors
> like this:
> s3# truss /bin/echo hello
> truss: cannot open /proc/39477/mem: No such file or directory
> truss: cannot open /proc/curproc/mem: No such file or directory
> s3# 

Is the /proc filesystem mounted?

R.F.Smith ( Please send e-mail as plain text.
public key:
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-amd64 mailing list