Yikes! Dire trouble with 9500S-4 installation :(((

ray at redshift.com ray at redshift.com
Mon Nov 28 12:55:07 GMT 2005

At 10:49 AM 11/28/2005 +0100, Olaf Greve wrote:
| Hi all,
| Firstly: thanks a lot for all your replies, they were actually very 
| helpful in deciding what to install, and I'll get back to them a bit 
| further ahead in this message...
| However, unfortunately, last weekend Murphy struck, correction, he 
| struck raised to the power of three. :(
| Firstly, we were hit by a blizzard over here on Friday, effectively 
| knocking out most roads, and hence depriving Versatel of the means to 
| install the new ADSL modem at our home. So, off to a bad start, I have 
| been Internet-less at home as of last Wednesday, and it will not be 
| before tomorrow that they'll install it. Furthermore, due to the same 
| reason, the machine could not be delivered to my home on Friday.
| Secondly, on Saturday, the client and I made a brave effort to force 
| luck our way by going to the site where the machine is at (not exactly 
| straightforward due to the snow). When we were finally there, we could 
| at least get some hands-on work done. A nice surprise for me was that 
| the guy who normally assembles the machines was ill, so the client 
| worked on that, while I read through the various messages regarding the 
| 9500S-4 + FreeBSD 5.4 vs. 6, etc. When that was done, I had a strategy 
| set out (FreeBSD 6.0 + MySQL 4.1.x built from the ports), and gave the 
| client some help in assembling the machine.
| Once that was out of the way, I booted up the machine, configured the 
| RAID 10 array as I would on any RAID controller (no surprises there), 
| and then I decided to give FreeBSD 6 a go (I actually agree with Ray on 
| preferring to stick with "non .0" versions, but given the other messages 
| I gather that FreeBSD 6.0 has actually already been pounded on a lot).
| Surprise, surprise, stuff did not work as expected. Firstly, FreeBSD 
| choked on the Gigabit NICs we had installed, and then on the RAID 
| controller. I tried various things, removed the NICs, verified the RAID 
| array from the controller's BIOS itself (checked out all ok), tried the 
| various different settings with enabling/disabling the write cache etc., 
| tried it with FreeBSD 5.4 and all to no avail. :((((
| Very frustrating. To compound matters, it started to snow heavily again, 
| so we had to dig the car out and head back for our living places. We 
| decided to leave the machine at the client's site as we didn't want to 
| risk it getting damaged and I didn't have Internet at home anyway.
| Nowwwww, does anyone have any ideas what could be wrong? To give a bit 
| more detail, the machine has an Asus motherboard with 939 socket (dunno 
| the number from memory (but if deemed relevant I can request it), but 
| it's something like the K8N or A8N or so), and the processor is an 
| Athlon dual core 4400. The 9500S-4 is installed in a normal 32-bit PCI 
| slot, and I cannot see any hardware errors (FreeBSD recognises it as 
| well), and the RAID verification went fine (though of course there is no 
| data yet on the drives). The drives are Maxtor drives of 189Gb each 
| (dunno the exact type number) and they were recognised properly by the 
| controller.
| Yet, upon booting, it is very weird that the NICs (or at least one of 
| them) and the 9500S-4 all gave trouble, especially since all of them are 
| brand new. I _think_ we didn't make any errors in the assembly of the 
| machine, but given the trouble I cannot be 100% sure. The errors given 
| by FreeBSD 5.4 and 6 all seem to be related to the twa interrupt handler 
| (I hope I identified that correctly).
| I didn't write down the very error messages, but I did Google them when 
| I was over there and the only hits I found were basically the various 
| sources of the driver. By doing a Google search just now, I found one 
| such example at (note: this may not be the very driver that 5.4 or 6 
| uses, but it should indicate the same source of error): 
| http://fxr.watson.org/fxr/source/dev/twa/tw_cl_intr.c
| The types of errors I saw passing by were things like:
| "Failed to fetch AEN"
| "Response queue empty"
| "Unposted command completed"
| I _think_ I've seen the first two, and I've definitely seen that last 
| error message.
| When doing a more general search on these issues in Google using the 
| terms "3ware freebsd twa interrupt", I found several more people who've 
| had issues, but none of them sound like te very thing that happened to me.
| The nasty thing is that this goes wrong already upon booting from the 
| installation CD and once FreeBSD enters sysinstall, it doesn't find any 
| drives, so there's no chance for me to first install it and then fix the 
| driver or so...
| Any help/ideas would be greatly appreciated....
| Cheers, and thanks a lot in advance!
| Olafo
| PS: I didn't try booting in any other mode than the default one; perhaps 
|   one of the other modes works better???

Hi Olaf,

  I've never run across any problem like that, although I've always only used
two brands of motherboard for servers (supermicro & tyan).  ASUS is also good
however and if I used 3 brands, ASUS would probably be the next on my list of
brands to use.

  Your problem sort of sounds like an IRQ conflict, but that's just a guess.
You might try going into the BIOS on the motherboard and disabling/remove the
NIC's for a moment and see if that makes any difference.  I would also disable
USB, the parallel printer port, and the serial port(s) in the BIOS if you don't
need them.  Even if you do need them, it might not be a bad idea to try that.
My thinking is that this might free up some IRQ channels for the 3ware card (if
there is in fact some conflict there).

  I would also make sure spread spectrum is disabled in the BIOS, since that can
cause funny problems sometimes (it's a technology to limit or "cloak" RF coming
from the machine - more or less - and you don't need it).  

  I would also take the 3ware card out and try doing an install on the machine
with a normal old IDE drive, just to see if it is in fact something about the
3ware card that the problem is related to.  I would also install the 3ware card
in the slot closes to the AGP slot, since that slot usually is the fastest, etc.
 Are there any other cards installed?  If so, remove them and see if that
changes anything.

  I would also check the BIOS and if you are not using IDE (while the 3ware is
installed) I would disable the primary and secondary IDE channels (assuming you
do not have a local CD-ROM/DVD).  On our servers, I have an external USB floppy
and external USB CD-ROM that I use for installation, then once FreeBSD is up and
running, I disable USB and unplug those (since our servers don't require floppy
or CD's, etc.)

  While you are searching google next time, you might try searching for the
make/model of your motherboard and FreeBSD or something along those lines.
People often forget how much impact the motherboard and chipset can have on

  BTW, since you have been removing cards and stuff, you might try removing all
the card and then doing a CMOS clear.  Then boot and configure the BIOS.  Then
power down, install just the 3ware card, boot up, then try installing FreeBSD
without anything else.  That might help the 3ware card recognize a different IRQ
or something.

  Keep everyone posted.  If I think of anything else, I will e-mail you.


More information about the freebsd-amd64 mailing list