Yikes! Dire trouble with 9500S-4 installation :(((

Olaf Greve ogreve at millennics.com
Mon Nov 28 09:50:55 GMT 2005

Hi all,

Firstly: thanks a lot for all your replies, they were actually very 
helpful in deciding what to install, and I'll get back to them a bit 
further ahead in this message...

However, unfortunately, last weekend Murphy struck, correction, he 
struck raised to the power of three. :(

Firstly, we were hit by a blizzard over here on Friday, effectively 
knocking out most roads, and hence depriving Versatel of the means to 
install the new ADSL modem at our home. So, off to a bad start, I have 
been Internet-less at home as of last Wednesday, and it will not be 
before tomorrow that they'll install it. Furthermore, due to the same 
reason, the machine could not be delivered to my home on Friday.

Secondly, on Saturday, the client and I made a brave effort to force 
luck our way by going to the site where the machine is at (not exactly 
straightforward due to the snow). When we were finally there, we could 
at least get some hands-on work done. A nice surprise for me was that 
the guy who normally assembles the machines was ill, so the client 
worked on that, while I read through the various messages regarding the 
9500S-4 + FreeBSD 5.4 vs. 6, etc. When that was done, I had a strategy 
set out (FreeBSD 6.0 + MySQL 4.1.x built from the ports), and gave the 
client some help in assembling the machine.

Once that was out of the way, I booted up the machine, configured the 
RAID 10 array as I would on any RAID controller (no surprises there), 
and then I decided to give FreeBSD 6 a go (I actually agree with Ray on 
preferring to stick with "non .0" versions, but given the other messages 
I gather that FreeBSD 6.0 has actually already been pounded on a lot).

Surprise, surprise, stuff did not work as expected. Firstly, FreeBSD 
choked on the Gigabit NICs we had installed, and then on the RAID 
controller. I tried various things, removed the NICs, verified the RAID 
array from the controller's BIOS itself (checked out all ok), tried the 
various different settings with enabling/disabling the write cache etc., 
tried it with FreeBSD 5.4 and all to no avail. :((((

Very frustrating. To compound matters, it started to snow heavily again, 
so we had to dig the car out and head back for our living places. We 
decided to leave the machine at the client's site as we didn't want to 
risk it getting damaged and I didn't have Internet at home anyway.

Nowwwww, does anyone have any ideas what could be wrong? To give a bit 
more detail, the machine has an Asus motherboard with 939 socket (dunno 
the number from memory (but if deemed relevant I can request it), but 
it's something like the K8N or A8N or so), and the processor is an 
Athlon dual core 4400. The 9500S-4 is installed in a normal 32-bit PCI 
slot, and I cannot see any hardware errors (FreeBSD recognises it as 
well), and the RAID verification went fine (though of course there is no 
data yet on the drives). The drives are Maxtor drives of 189Gb each 
(dunno the exact type number) and they were recognised properly by the 

Yet, upon booting, it is very weird that the NICs (or at least one of 
them) and the 9500S-4 all gave trouble, especially since all of them are 
brand new. I _think_ we didn't make any errors in the assembly of the 
machine, but given the trouble I cannot be 100% sure. The errors given 
by FreeBSD 5.4 and 6 all seem to be related to the twa interrupt handler 
(I hope I identified that correctly).

I didn't write down the very error messages, but I did Google them when 
I was over there and the only hits I found were basically the various 
sources of the driver. By doing a Google search just now, I found one 
such example at (note: this may not be the very driver that 5.4 or 6 
uses, but it should indicate the same source of error): 
The types of errors I saw passing by were things like:
"Failed to fetch AEN"
"Response queue empty"
"Unposted command completed"

I _think_ I've seen the first two, and I've definitely seen that last 
error message.

When doing a more general search on these issues in Google using the 
terms "3ware freebsd twa interrupt", I found several more people who've 
had issues, but none of them sound like te very thing that happened to me.

The nasty thing is that this goes wrong already upon booting from the 
installation CD and once FreeBSD enters sysinstall, it doesn't find any 
drives, so there's no chance for me to first install it and then fix the 
driver or so...

Any help/ideas would be greatly appreciated....

Cheers, and thanks a lot in advance!

PS: I didn't try booting in any other mode than the default one; perhaps 
  one of the other modes works better???

More information about the freebsd-amd64 mailing list