twa breakage on AMD64 with 3wareversionand2005-01-1103:00:49 UTC RELENG_5 commit

Jean-Yves Avenard jean-yves.avenard at
Sat Jan 15 00:20:00 PST 2005


On 15/01/2005, at 12:40 PM, Vinod Kashyap wrote:

> I tried reproducing the problem on both i386 and amd64,
> but could not.  I installed 5.3 RELEASE, cvsuped to the
> tip of RELENG_5, re-built the kernel with twa integrated,
> and rebooted.  The test systems booted just fine (off of
> 3ware controlled da0).  I even tried replacing just the
> twa sources of 5.3 RELEASE with the twa sources from the
> tip of RELENG_5, and that worked fine too.  All this,
> without even upgrading the firmware from (which
> is bundled into 5.3 RELEASE sources).  So, I am confused as
> to what might be happening.
> Could you give the attached patch a try?  Just a hunch...

Here is what the screen look like:
Copyright (c) 1992-2004 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
	The Regents of the University of California. All rights reserved.
FreeBSD 5.3-STABLE #2: Sun Nov 28 13:39:08 EST 2004
     avenardj at
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: AMD Opteron(tm) Processor 248 (2190.63-MHz K8-class CPU)
   Origin = "AuthenticAMD"  Id = 0xf5a  Stepping = 10
   AMD Features=0xe0500800<SYSCALL,NX,MMX+,LM,3DNow+,3DNow>
real memory  = 1073676288 (1023 MB)
avail memory = 1025294336 (977 MB)
MADT: Forcing active-low polarity and level trigger for SCI
ioapic0 <Version 1.1> irqs 0-23 on motherboard
ioapic1 <Version 1.1> irqs 24-27 on motherboard
ioapic2 <Version 1.1> irqs 28-31 on motherboard
acpi0: <A M I OEMRSDT> on motherboard
acpi0: Power Button (fixed)
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x5008-0x500b on acpi0
cpu0: <ACPI CPU> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pcib1: <ACPI PCI-PCI bridge> at device 6.0 on pci0
pci3: <ACPI PCI bus> on pcib1
ohci0: <OHCI (generic) USB controller> mem 0xfeafc000-0xfeafcfff irq 19  
at device 0.0 on pci3
usb0: OHCI version 1.0, legacy support
usb0: <OHCI (generic) USB controller> on ohci0
usb0: USB revision 1.0
uhub0: AMD OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 3 ports with 3 removable, self powered
ohci1: <OHCI (generic) USB controller> mem 0xfeafd000-0xfeafdfff irq 19  
at device 0.1 on pci3
usb1: OHCI version 1.0, legacy support
usb1: <OHCI (generic) USB controller> on ohci1
usb1: USB revision 1.0
uhub1: AMD OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 3 ports with 3 removable, self powered
pci3: <display, VGA> at device 6.0 (no driver attached)
fxp0: <Intel 82551 Pro/100 Ethernet> port 0xbc00-0xbc3f mem  
0xfeaa0000-0xfeabffff,0xfeafb000-0xfeafbfff irq 18 at device 8.0 on  
miibus0: <MII bus> on fxp0
inphy0: <i82555 10/100 media interface> on miibus0
inphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
fxp0: Ethernet address: 00:e0:81:29:c0:30
isab0: <PCI-ISA bridge> at device 7.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <AMD 8111 UDMA133 controller> port  
0xffa0-0xffaf,0x376,0x170-0x177,0x3f6,0x1f0-0x1f7 at device 7.1 on pci0
ata0: channel #0 on atapci0
ata1: channel #1 on atapci0
pci0: <serial bus, SMBus> at device 7.2 (no driver attached)
pci0: <bridge, PCI-unknown> at device 7.3 (no driver attached)
pcib2: <ACPI PCI-PCI bridge> at device 10.0 on pci0
pci2: <ACPI PCI bus> on pcib2
ahd0: <Adaptec AIC7902 Ultra320 SCSI adapter> port  
0xac00-0xacff,0xa000-0xa0ff mem 0xfc8fc000-0xfc8fdfff irq 24 at device  
6.0 on pci2
aic7902: Ultra320 Wide Channel A, SCSI Id=7, PCI-X 67-100Mhz, 512 SCBs
ahd1: <Adaptec AIC7902 Ultra320 SCSI adapter> port  
0xa400-0xa4ff,0xa800-0xa8ff mem 0xfc8fe000-0xfc8fffff irq 25 at device  
6.1 on pci2
aic7902: Ultra320 Wide Channel B, SCSI Id=7, PCI-X 67-100Mhz, 512 SCBs
bge0: <Broadcom BCM5704C Dual Gigabit Ethernet, ASIC rev. 0x2003> mem  
0xfc8a0000-0xfc8affff,0xfc8b0000-0xfc8bffff irq 24 at device 9.0 on  
miibus1: <MII bus> on bge0
brgphy0: <BCM5704 10/100/1000baseTX PHY> on miibus1
brgphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseTX,  
1000baseTX-FDX, auto
bge0: Ethernet address: 00:e0:81:29:c0:b0
bge1: <Broadcom BCM5704C Dual Gigabit Ethernet, ASIC rev. 0x2003> mem  
0xfc8d0000-0xfc8dffff,0xfc8e0000-0xfc8effff irq 25 at device 9.1 on  
miibus2: <MII bus> on bge1
brgphy1: <BCM5704 10/100/1000baseTX PHY> on miibus2
brgphy1:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseTX,  
1000baseTX-FDX, auto
bge1: Ethernet address: 00:e0:81:29:c0:b1
pci0: <base peripheral, interrupt controller> at device 10.1 (no driver  
pcib3: <ACPI PCI-PCI bridge> at device 11.0 on pci0
pci1: <ACPI PCI bus> on pcib3
3ware device driver for 9000 series storage controllers, version:
twa0: <3ware 9000 series Storage Controller> port 0x9800-0x98ff mem  
0xfb800000-0xfbffffff,0xfc6ffc00-0xfc6ffcff irq 29 at device 1.0 on  

 From there it just hangs...
The drive activity LED will be lit for about 10s and after that goes  

The more it goes, the more I'm thinking of reverting to i386 mode, the  
amd64 just keeps crashing about once a fortnight.


Jean-Yves Avenard
Hydrix Pty Ltd - Embedding the net | fax +61 3 9572 2686 | phone +61 3 9572 0686 ext 100
VoIP: direct: 100 at, general: info at

More information about the freebsd-amd64 mailing list