java/jdk15 help [SOLVED?]

Jon Kuster kwsn at
Thu Apr 21 23:53:04 PDT 2005

On Fri, 2005-04-22 at 07:26 +0200, Ernst W. Winter wrote:
> On Fri, 22 Apr 2005, Palle Girgensohn wrote:
> > 
> > --On tisdag, mars 22, 2005 08.37.19 -0500 Damian Gerow 
> > <dgerow at> wrote:
> > 
> > >Thus spake Damian Gerow (dgerow at [19/03/05 08:44]:
> > >: I've noticed that a few people here have successfully gotten a native
> > >: java/jdk15 built.  Can one of those people lend me a hand, please?
> > >:
> > >: I've installed linux-sun-jdk-, and worked around the wonky
> > >problem : thrown by the jdk15 build.  But afterwards, all I seem to get
> > >is hung javac : processes, each consuming 100% of CPU.
> > >
> > >By some ridiculous fluke, I tried a build with WITH_IPV6 defined.  It
> > >built without any issue whatsoever, and has now been installed.  So I at
> > >least have a JDK at this point; now to try to figure out how/why it's
> > >failing when I don't want IPV6 support.
> > 
> > Are you sure about this? I mean that it all worked when compiling 
> > WITH_IPV6?
> > 
> I haven't tried this one, but mine is working well.
> > I'm trying to get the linux-sun-jdk- javac to compile
> > anything, but it just starts consuming 100% forever for a simple
> > hello world app.  There's no way it could build anything? What
> > gives? Same thing happens when running the port jdk15 port gets to
> > the javac part, or even running jar...
> > 
> Hmm, I owuld say some settings are not right by the sound of this.
> > I just noticed that it does not happen every time. I managed to run
> > linux 1.4 javac on a simple hello world app a dozen times in a row,
> > but on the thirteenth time it stuck, and the two javac processes
> > required a kill -9 to die.
> > 

This sounds exactly like the problems were were experiencing.

> NO problem here to run Linuz Apps.
> > This is on a Dell 2850 dual CPU (with hyperthreading, so four
> > "virtual" cpus), so it is not really an AMD64, but "EMT64".
> > 
> MIne is a single 939 with ASUS MB.
> > I'm quite amazed that I see reports of java working on amd64. On
> > this machine it is completely impossible, as linux bootstrapping
> > jdk hangs all the time. Most other things work on the machine,
> > although I've experienced some stability problems. Could it be a
> > hardware problem?
> >
> NOt likeley form what I can say, try to contact:
> Jon Kuster <kwsn at>
> as I helped him a bit to get his problem fixed and from what I
> remember he had the same machine. Say hello form me.

Hi Ernst :) I've got an 1850, which I think is the same as a 2850,
except in 1U form. I doubt it's a hardware problem.  I'm guessing it's a
problem somewhere in the linux32 code, but I don't know for sure.  Since
I wasn't able to determine the real problem, I can't give a surefire
solution, but I do have some tips:

1. While you're building jdk15, switch to a UP kernel as it seems to
help make the linux-sun-jdk14 a bit more stable.
2. Reinstall linux_base-8 and everything it depends on and everything
that depends on it (don't know that this actually helps, but it can't
3. Make sure linprocfs is mounted.
4. Apply the patch in this message, or jdk15 will abort with SIGILL on
your Xeons:
5. During the build, make sure the box is as idle as possible. Make sure
nothing more intensive than top is active (watching compile messages
scroll by is OK).
6. Even if you have no problems with java during the build, it will die
with an error about 2/3rds of the way through.  Ernst provided me with
some notes that got me around this error, so I'll reproduce them here:

i had the same problem and solved it executing the last command which
caused the error manually. Looks like the error comes because it's a
very long command. Just put the command that comes between 'then' and
'fi' in a shell file and execute it manually in the directory
work/j2sre/make/java/java (I'm not seating now in my amd64 FreeBSD
computer but I think that was the directory). The compilation will go
on without any problem if you resume it afterwards with a 'make

Try 'make build |& tee build.out' (if your shell is csh or tcsh)
'make build 2>&1 | tee build.out' (if sh or bash). After the
comes, edit build.out and you will see the command causing it
about two pages). 

After you restart the build, it might hang again with your java problem
- it did for me once.  All I can say is kill it, do a make clean,
reapply the patch, and start the build again.  On the bright side, once
you do manage to get jdk15 built and installed, it should be quite
stable.  We haven't been able to get our to fail yet on UP or SMP with a
-j12 buildworld going on in the background.

Hope this helps.


More information about the freebsd-amd64 mailing list