java/jdk15 help [SOLVED?]

Palle Girgensohn girgen at
Thu Apr 21 15:32:26 PDT 2005

--On tisdag, mars 22, 2005 08.37.19 -0500 Damian Gerow 
<dgerow at> wrote:

> Thus spake Damian Gerow (dgerow at [19/03/05 08:44]:
> : I've noticed that a few people here have successfully gotten a native
> : java/jdk15 built.  Can one of those people lend me a hand, please?
> :
> : I've installed linux-sun-jdk-, and worked around the wonky
> problem : thrown by the jdk15 build.  But afterwards, all I seem to get
> is hung javac : processes, each consuming 100% of CPU.
> By some ridiculous fluke, I tried a build with WITH_IPV6 defined.  It
> built without any issue whatsoever, and has now been installed.  So I at
> least have a JDK at this point; now to try to figure out how/why it's
> failing when I don't want IPV6 support.

Are you sure about this? I mean that it all worked when compiling 

I'm trying to get the linux-sun-jdk- javac to compile anything, 
but it just starts consuming 100% forever for a simple hello world app. 
There's no way it could build anything? What gives? Same thing happens when 
running the port jdk15 port gets to the javac part, or even running jar...

I just noticed that it does not happen every time. I managed to run linux 
1.4 javac on a simple hello world app a dozen times in a row, but on the 
thirteenth time it stuck, and the two javac processes required a kill -9 to 

This is on a Dell 2850 dual CPU (with hyperthreading, so four "virtual" 
cpus), so it is not really an AMD64, but "EMT64".

I'm quite amazed that I see reports of java working on amd64. On this 
machine it is completely impossible, as linux bootstrapping jdk hangs all 
the time. Most other things work on the machine, although I've experienced 
some stability problems. Could it be a hardware problem?


More information about the freebsd-amd64 mailing list