64-bit HAL for ath_hal module

Jung-uk Kim jkim at niksun.com
Tue Sep 21 14:36:40 PDT 2004

On Monday 20 September 2004 07:15 pm, RIchard N. Fogle wrote:
> Greetings,
>   There is a 64-bit HAL for the Atheros chipset in the CVS version
> of madwiki..  Any chance that will be included in the ath_hal
> device for AMD64 FreeBSD?  I made an attempt at getting this to
> work myself by dropping in the 64-bit, but received a missing
> symbol of
> "ath_hal_memcpy" when loading the driver.
>   I then defined "ath_hal_memcpy" as "bcopy((_src), (_dst),
> (_size))" as required in ah_osdep.h, and with a version change, the
> module loded successfully with the device found.  Unfortunately,
> when I try to manipulate it after an "ifconfig ath0 up" I get a
> kernel panic. Honestly didn't think it would be that easy, but I
> thought I'd try. I have a copy of the 64-bit HAL if anyone needs
> it..  Something changed somewhere but I'm not all that experienced
> in this sort of thing.  Until then I'm running i386/FreeBSD
> 5.3BETA3 on my dual Opteron.  Tried Fedora but it gave me fits. 
> I'm probably in the minority, but wireless is the only method I
> have for connecting to the interenet.

Have you tried this?


I haven't tried it myself but it seems to have the ath_hal_memcpy() 
and so on.

Just my 2 cents...

Jung-uk Kim

> Regards,
> Rich

More information about the freebsd-amd64 mailing list