XFree86 vesa and radeon 9600 driver voor AMD64

Jem Matzan valour at thejemreport.com
Tue May 18 17:06:43 PDT 2004

Willem Jan Withagen wrote:

>----- Original Message ----- 
>From: "Peter Wemm" <peter at wemm.org>
>>>Was there any particular reason why the vesa is not included in the
>>>ISO 5.2.1 CD package....
>>The vesa module uses vm86 or bios calls from the kernel.  Those are not 
>>possible in a 64 bit kernel.
>I hate to agrue with you because you seem te be much more knowledgable
>on this than I am, BUT .......
>I did not know this and just compiled vesa..... installed it.
>And this is currently running... xvidtune "complains" that there is 
>nothing to tune. 
>So I guess it must be running vesa?? How did this get to work then?
>And yes, I am running amd64 in 64 bit mode...
>hw.machine: amd64
>hw.model: AMD Opteron(tm) Processor 242
>hw.ncpu: 2
>XFree86 Version 4.3.0
>Release Date: 27 February 2003
>X Protocol Version 11, Revision 0, Release 6.6
>Build Operating System: FreeBSD 5.2 amd64 [ELF]
>Build Date: 17 May 2004
>(II) VESA: driver for VESA chipsets: vesa
>(II) Primary Device is: PCI 01:00:0
>(--) Chipset vesa found
>(II) VESA(0): initializing int10
>(==) VESA(0): Write-combining range (0xa0000,0x20000) was already clear
>(==) VESA(0): Write-combining range (0xc0000,0x40000) was already clear
>(II) VESA(0): Primary V_BIOS segment is: 0xc000
>(==) VESA(0): Write-combining range (0x0,0x1000) was already clear
>(II) VESA(0): VESA BIOS detected
>(II) VESA(0): VESA VBE Version 2.0
>(II) VESA(0): VESA VBE Total Mem: 131072 kB
>(II) VESA(0): VESA VBE OEM Software Rev: 1.0
>(II) VESA(0): VESA VBE OEM Vendor: ATI Technologies Inc.
>(II) VESA(0): VESA VBE OEM Product: V350
>(II) VESA(0): VESA VBE OEM Product Rev: 01.00
>(==) VESA(0): Depth 16, (--) framebuffer bpp 16
>(==) VESA(0): RGB weight 565
>(==) VESA(0): Default visual is TrueColor
>(==) VESA(0): Using gamma correction (1.0, 1.0, 1.0)
>(II) LoadModule: "ddc"
>(II) Loading /usr/X11R6/lib/modules/libddc.a
>(II) Module ddc: vendor="The XFree86 Project"
>        compiled for 4.3.0, module version = 1.0.0
>        ABI class: XFree86 Video Driver, version 0.6
>(II) VESA(0): VESA VBE DDC supported
>(II) VESA(0): VESA VBE DDC Level 2
>(II) VESA(0): VESA VBE DDC transfer in appr. 2 sec.
>(II) VESA(0): VESA VBE DDC read successfully
>(II) VESA(0): Manufacturer: PHL  Model: 801  Serial#: 109398
>(II) VESA(0): Year: 2001  Week: 14
>(II) VESA(0): EDID Version: 1.3
>(II) VESA(0): Digital Display Input
>(II) VESA(0): Max H-Image Size [cm]: horiz.: 34  vert.: 27
>(II) VESA(0): Gamma: 2.10
>(II) VESA(0): DPMS capabilities: StandBy Suspend Off; RGB/Color Display
>And it goes on forever and forever, listing just about any vesa mode
>ever invented by mankind
>Looks pretty complete to me??
>>>I have an ATI radeon 9600 video card, and that driver seems to be
>>>the only one I can get X to work with on amd64....
>>>Next to the fact that configuration of it, is horribly simple.
>>>And thus would be a good target to get people quick online with a
>>>simple XConfig.
>>I had to use a newer XFree86 that had updated drivers for my radeon 
>>7000.  It wasn't pretty, to say the least.
>>I currently run this at home:
>>vendor string:    The XFree86 Project, Inc
>>vendor release number:    40400000
>>XFree86 version: 4.4.0
>>But.. I had to do unspeakable things to it to make it compile.  The 
>>XFree86 folks really truely screwed things up.
>Well I'm trying to get a old 32-bit set of compiler tools on line on 
>amd64. Gives me the same sort of feeling.....
>I tried using the Server-snap port, but i claims it does not compile
>on amd64 .... 
>freebsd-amd64 at freebsd.org mailing list
>To unsubscribe, send any mail to "freebsd-amd64-unsubscribe at freebsd.org"
If you compile XFree86 from Ports, it should add a VESA driver. It did 
for me anyway. The package does not have it. If you search through this 
list, last winter I came across this problem and I thought someone said 
they fixed it.


More information about the freebsd-amd64 mailing list