Still can't get -current, was Re: getting -current???

stuart nichols stu at
Thu Jul 29 11:55:29 PDT 2004

On Wed, 28 Jul 2004, Matt Douhan wrote:

> On Wednesday 28 July 2004 22.12, stuart nichols wrote:

> > On Wed, 28 Jul 2004, Adriaan de Groot wrote:

> > > 5.2.1 is old and klunky. Update to -CURRENT for an all-around nicer
> > > experience (like, modules, like, cvsup, like, everything). There are even
> > > snapshots available from sesnap - check the recent archives of this list.
> > OK, but I can't figure out how to get -current.  I tried the miniinst CD
> > 5-20040324-CURRENT-amd64-miniinst.iso, and it drops into debug mode.  This

> 20040324 - CURRENT is like from the stoneage, get a newer version, ade
> suggeste SESNAP which can be found at where we build
> daily snaps for AMD64, that would give you a new CURRENT and us a chance to
> know if they work :)

I grabbed and burned the 5.2-CURRENT-20040727-SESNAP.iso file from (it appears that the
0728 and 0729 builds busted).  The CD boots fine and I get a regular
install screen.  The custom page works normally up to the point where I
commit, and then it can't find the files it needs from

The installer sets its release name to 5.2-CURRENT, which is not found on
any server I tried.  I am not sure what path it checks for these files.

I tried setting the release name to 5.2-CURRENT-20040727-SESNAP (there is
such a directory, but there do not appear to be any dist files ) and even
to /snapshots/amd64/5.2-CURRENT-20040727-SESNAP but that didn't work.  I
poked around for something like -current, but couldn't find one.

So how do I natively get a -current for AMD64?  I apparently need step by
step instructions.  I've built countless i386 boxes, so I know the install
process.  I don't want to start with an i386 build for this processor;
I want to use native amd64 software the whole way (the i386 build works
just fine on this processor).

This whole thing started out with me trying to do an update for AMD64
5.2.1-RELEASE, which was lacking cvsup.  I'm testing things out because I
am about to issue a PO for 4 dual-Opteron servers and I want to have the
details ironed out about the OS install and what to specify for
motherboard/CPU combos before I issue a PO.  I would prefer a -RELEASE
that is updatable, since I want to put these servers into production, but
I'd at least like to get SOMETHING running properly before the new servers
arrive.  5.2.1-RELEASE AMD64 ran fine, by the way;  I just couldn't update
it in the usual way, so I asked about what happened to cvsup.

I have an MSI K8T Neo motherboard, with an Athalon64 2800+.  I am willing
(quite willing) to provide testing and other help with the AMD64


stuart nichols
CAPnet Network Operations

More information about the freebsd-amd64 mailing list