cvsup RELENG_5_2 deletes make files and most of source

David Kaplowitz dkaplowitz at
Sat Jul 10 11:05:00 PDT 2004

Hi there,

I've been googling around for an answer to this apparent problem, but
am not getting anywhere with it. When I run cvsup with the tag
RELENG_5_2, I see all manner of (seemingly legit) files being deleted,
but nothing actually gets added/checked out. Viewing the contents of
/usr/src after this update, I see about 21 directories, but no make
files and if I run "make buildworld" in /usr/src I get a "make: don't
know how to make buildworld. Stop". The size of /usr/src after this
update is ~31MB.

If I run the same command with a supfile with the tag=. flag set,
everything updates, nothing gets deleted, but I can't run make
buildworld successfully. I get all manner of errors --- and I'd prefer
to run -STABLE rather than -CURRENT, unless there's some compelling
reason to run -CURRENT on this machine.

I've deleted and reinstalled /usr/src about 8 times now and have
decided to ask for some help with this.

The system is 5.2.1-R on a MSI Neo K8T FIS2R mobo with an AMD 3200+
with ddr 400/pc3200 RAM and an SATA HDD.

I'm running cvsup-without-gui-16.1h with the command "cvsup -g -L 2
src-supfile" using a supfile with the following contents:


*default base=/usr
*default delete
*default prefix=/usr
*default release=cvs
*default use-rel-suffix
*default tag=RELENG_5_2



*default base=/usr
*default delete
*default prefix=/usr
*default release=cvs
*default use-rel-suffix
*default tag=. 


I've also tried with variations on these contents, but overall
anything I do with RELENG_5_2 set deletes /usr/src down to ~31MB and
no ability to make buildworld in /usr/src.

Thanks to anyone who can tell me what silly thing I'm missing in this
set up that's causing this issue.



More information about the freebsd-amd64 mailing list