aic7xxx timeout errors on boot
Jim Shepherd
jimshep at mindspring.com
Tue Mar 14 15:44:05 PST 2000
I am receiving timeout errors on boot preventing the OS to load when
using an old CDROM drive and a Quantum Atlas IV drive:
SCSI: aborting command due to timeout: pid 0, scsi0, channel 0, id 4,
lun 0, Test Unit Ready 00 00 00 00 00
SCSI host 0 abort (pid 0) timed out - resetting
SCSI bus is being reset for host 0 channel 0
(last 2 lines repeat indefinitely)
With the same hardware configuration, I did not receive these errors
with the Linux 2.2.3 kernel, but they I first came across them with the
2.2.10 kernel. Also using the Adaptec SCSI software under DOS does not
result in any obvious errors (no errors are displayed during loading).
I have looked through the archives and looked at termination issues as
well as trying the "no_reset", "panic_on_abort", and "override_term"
parameters at bootup. Following is my configuration. If I provide
anything else that would be usefull, please let me know. Thanks in
advance.
System Configuration:
Redhat Linux 6.1 with 2.3.49 kernel (aic7xxx support is compiled into
the kernel)
AIR 54TPI motherboard with on board AIC-7880P SCSI chip
68 pin connector
Quantum Atlas IV 9GB harddrive
End of ribbon cable is terminated
50 pin connector
Chinon CDS-535 Internal CDROM Drive (SCSI-2 drive)
End of ribbon cable is terminated
(Have also tried using middle connector on ribbon attached to
motherboard connector and terminating both ends)
No IDE devices
Information from /proc:
Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
Vendor: QUANTUM Model: ATLAS IV 9 WLS Rev: 0808
Type: Direct-Access ANSI SCSI revision: 03
Adaptec AIC7xxx driver version: 5.2.0/3.2.4
Compile Options:
TCQ Enabled By Default : Disabled
AIC7XXX_PROC_STATS : Disabled
AIC7XXX_RESET_DELAY : 5
Adapter Configuration:
SCSI Adapter: Adaptec AIC-7880 Ultra SCSI host adapter
Ultra Wide Controller at PCI 0/8/0
PCI MMAPed I/O Base: 0xfebfb000
Adapter SEEPROM Config: SEEPROM found and used.
Adaptec SCSI BIOS: Enabled
IRQ: 10
SCBs: Active 0, Max Active 1,
Allocated 31, HW 16, Page 255
Interrupts: 3679
BIOS Control Word: 0x18b6
Adapter Control Word: 0x005c
Extended Translation: Enabled
Disconnect Enable Flags: 0xffff
Ultra Enable Flags: 0x0000
Tag Queue Enable Flags: 0x0000
Ordered Queue Tag Flags: 0x0000
Default Tag Queue Depth: 8
Tagged Queue By Device array for aic7xxx host instance 0:
{255,255,255,255,255,255,255,255,255,255,255,255,255,255,255,255}
Actual queue depth per device for aic7xxx host instance 0:
{1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1}
Statistics:
(scsi0:0:0:0)
Device using Wide/Sync transfers at 20.0 MByte/sec, offset 8
Transinfo settings: current(25/8/1/0), goal(25/8/1/0), user(25/15/1/0)
Total transfers 3612 (2650 reads and 962 writes)
To Unsubscribe: send mail to majordomo at FreeBSD.org
with "unsubscribe aic7xxx" in the body of the message
More information about the aic7xxx
mailing list