Problems with Adaptec 29160.....Weird..
Steffen Hansen
Steffen.hansen at dba.dk
Fri Jul 14 02:35:25 PDT 2000
Doug Ledford wrote:
> Steffen Hansen wrote:
> >
> > Hi.... And btw. I'm new so bear with me....
> >
> > I'm trying to install a new Linux RH6.2/Oracle
> > server with an Adaptec 29160 controller. So far
> > there's only two IBM18.5Gig drives attached to
> > the controller, but more will follow.
> >
> > The installation of RH6.2 causes no problems,
> > but when RH6.2 boots the std. SMP kernel, the
> > following messages appears when the Adaptec
> > driver loads :
> > ----------------------------------------------------------------------------
> >
> > (scsi0) <Adaptec AIC-7892 Ultra 160/m SCSI host adapter> found at PCI 0/16/0
> > (scsi0) Wide Channel, SCSI ID=7, 32/255 SCBs
> > (scsi0) Downloaded sequencer code... 392 instructions downloaded
> > scsi0 : Adaptec AHA274x/284x/294x (EISA/VLB/PCI-Fast SCSI) 5.2.1/5.2.0
> > <Adaptec AIC-7892 Ultra 160/m SCSI host adapter>
> > scsi : 1 host
> > scsi : aborting command due to timeout : pid 0, scsi0, channel 0, id 0, lun
> > 0 In
> > quiry 00 00 00 ff 00
> > (scsi0) BRKADRINT error (0xff):
> > Illegal Host Access
> > Illegal Sequencer address referenced
> > Illegal Opcode in sequencer program
> > Sequencer Ram Parity Error
> > Data-Path Ram Parity Error
> > Scratch Ram/SCB Array Ram Parity Error
> > PCI Error detected
> > CIOBUS Parity Error
> > (scsi0) SEQADDR=0x1ff
> > Kernel panic: aic7xxx: unrecoverable BRKADRINT
> >
> > In interrupt handler - not syncing
> >
> > ----------------------------------------------------------------------------
> >
> > This happens with the std. SMP kernel as well as with
> > Kernel 2.4.0-test1/2
> > The driver version in the 2.2.14 kernel is 5.1.28 and 2.4.0
> > reports 5.2.1...
> >
> > It does NOT however die when using the linux-up kernel
> > that comes with RH6.2.....
> >
> > I hope that you're able to help me...
>
> Well, not really. First off, this isn't an aic7xxx driver issue, I can almost
> guarantee that. The problem you are seeing is that in the smp kernel, the
> card's mmaped I/O space is simply going away. No reason, no excuse, the card
> simply isn't there anymore. It's there when we do the config stage, it's
> there enough for us to read the various config registers and figure out what
> the card is. But, by the time the first command is sent or shortly there
> after (likely before we send the command to be honest), the card is no longer
> present. When you see things like the BRKADRINT with a value of 0xff, then
> that usually means that the card is simply *gone* as far as the kernel driver
> is concerned. We can't work around things like that, and it is most likely a
> result of some other driver or something else in the kernel screwing around
> with the vm mappings in the kernel and making the MMAP I/O space disappear.
> You can try recompiling with the #define MMAPIO in the aic7xxx.c file
> commented out and see if it will work in SMP mode then.
>
With Kernel 2.4.0-test1 (aic7xxx version 5.2.0) and #define MMAPIO commented
out as Doug suggested, the server boots ok... BUT - (don't try this at home kids
;-)
weird stuff happens. X goes straight to h***.. Completely dead. Then when I'm
trying
to run Xconfigurator the server crashes. Even with magic sys key compiled into
the
kernel I can't do anything...
Anyway. I'll keep you posted as of what happens next :.--)
Tanx again..
Steffen Hansen
Den Blaa Avis A/S
Denmark
To Unsubscribe: send mail to majordomo at FreeBSD.org
with "unsubscribe aic7xxx" in the body of the message
More information about the aic7xxx
mailing list