[Bug 262920] bhyve: "/boot/userboot.so: Undefined symbol "getsecs"

From: <bugzilla-noreply_at_freebsd.org>
Date: Wed, 30 Mar 2022 06:22:59 UTC

            Bug ID: 262920
           Summary: bhyve: "/boot/userboot.so: Undefined symbol "getsecs"
           Product: Base System
           Version: 13.1-RELEASE
          Hardware: amd64
                OS: Any
            Status: New
          Severity: Affects Some People
          Priority: ---
         Component: bhyve
          Assignee: virtualization@FreeBSD.org
          Reporter: tech-lists@zyxst.net


Upgraded to stable/13-n250147-60338b80693

This server is host to several freebsd VMs.

They're started from a shell script that runs like this:

sh vmrun.sh -c 2 -m 32768M -t tap2 -d /data/freebsdvm.img freebsdvm

Upgraded (source upgrade) from 13.0-stable to 13.1-stable, rebooted, tried to
run the vm (the system hosts five freebsd vms), tried with any of them, get
this error:

 "/boot/userboot.so: Undefined symbol "getsecs"

strings showed getsecs was in userboot.so but not in bhyve

The fix was to build world and kernel *without* this:


You are receiving this mail because:
You are the assignee for the bug.