Re: Boot hangs up with Alderlake's intel GbE NIC

From: Tomoaki AOKI <>
Date: Mon, 23 May 2022 15:31:06 UTC
On Mon, 23 May 2022 16:44:02 +0900 (JST)
Yasuhiro Kimura <> wrote:

> Hello,
> 2 months ago I updated my home server to Intel Alderlake Core i3 12100
> and GIGABYTE H610I DDR4 (rev. 1.0) motherboard.
> The latter has onboard Intel GbE NIC. But unfortunately 13.0-RELEASE
> doesn't detect it. So I inserted Intel PCI-E GbE adaptor to the PCI-E
> slot of the motherbord and used it as network interface of the server.
> And now 13.1-RELEASE is released. I tried updating with
> `freebsd-update update -r 13.1-RELEASE`, `freebsd install` and
> `shutdown -r now`. But after that system hangs up in the middle of
> boot.
> At first boot stops after onboard Intel GbE NIC is detected.
> It keeps about a minute and then boot process resumes. But soon it
> stops again.
> I waited about 20 minites in this state but boot never go ahead.
> Removing PCE-E GbE adopter doesn't change the situation.
> I also tried boot image of 14.0-CURRENT 20220519 snapshot and boot
> hangs up just same as 13.1-RELEASE.
> ---
> Yasuhiro Kimura

Possibly not related (as it was P- E- core related complaint),
if vm.pmap.pcid_enabled tunable is non-zero, does it change anything if
you set it to 0 in /boot/loader.conf to disable pcid?

In February, discussion about AlderLake CPU were in -current ML,
starting from [1] and disabling pcid was proposed by kib@ at [2].

Looking sysctl descrintion, I "feel" this can affect P- core only
AlderLake, too.

% sysctl -d vm.pmap.pcid_enabled
vm.pmap.pcid_enabled: Is TLB Context ID enabled ?

For example, it was 1 on Intel(R) Core(TM) i7-8750H CPU (Coffee Lake)
and on board Intel(R) I219-V CNP(7) is working as em0.
FreeBSD 13.1-STABLE #460 stable/13-n250911-b92a06875045-dirty, amd64.

So if I didn't miss any AlderLake-related commit, this would be 1
on AlderLake, too.



Tomoaki AOKI    <>