Re: Baikal Installation Issue

From: Doug Hardie <>
Date: Tue, 12 Sep 2023 08:25:47 UTC
> On Sep 11, 2023, at 03:40, Alexander Leidinger <> wrote:
> Am 2023-09-05 11:14, schrieb Doug Hardie:
>>> On Sep 5, 2023, at 02:00, Kurt Jaeger <> wrote:
>>>>> Does
>>>>> 	/usr/local/www/baikal/config/baikal.yaml
>>>>> exist ?
>>>> No.  That directory only has a .empty file in it.
>>> Then, have a look at the other mail from Ronald. I think you need
>>> to create it and add some relevant config.
>> Interesting.  I used the file from the web site and that gets around that error.  However, nowhere in any of the instructions did I find anything about that file or that it has to be created.  It is not in the package:
>> master# pkg info -l baikal | grep config
>> 	/usr/local/www/baikal/Core/Frameworks/BaikalAdmin/config.php
>> 	/usr/local/www/baikal/Core/Frameworks/Flake/config.php
>> 	/usr/local/www/baikal/config/.empty
>> 	/usr/local/www/baikal/vendor/twig/twig/.editorconfig
>> Thanks for all the assistance.  Now for some strange reason the web server is not including the REQUEST_URI.  I'll have to investigate that tomorrow.
> I tried this recently. The port doesn't chown some directories which are supposed to be owned by the webserver. So the ownership of those dirs/files is root instead of the typical www user. After "chown -R www:www /usr/local/www/baikal/Specific /usr/local/www/baikal/config" the web based config generation worked for me.

I encountered those issues.  They are easy to fix.  However, some other issues arose and eventually, I got tired of dealing with them and went back to Apple's servers.

-- Doug