Re: INDEX-12 gotten by portsnap is not updated

From: Colin Percival <>
Date: Fri, 05 May 2023 06:47:17 UTC
On 5/4/23 02:09, Felix Palmen wrote:
> * Colin Percival <> [20230503 23:42]:
>> My guess is that this is due to the Portsnap builder using an out-of-date
>> environment for running `make describe`; the ports commit in question
>> probably relies on something which changed in make(1) in the past decade.
>> I'm going to try to track this down as soon as I get a chance.
> Okay, now I have a better idea what this is about. I just checked with
> the make version in 12.4, and that worked fine.

Yeah, it looks like the change went into make(1) some time around 2020.  (I
found the change in NetBSD, but don't know exactly when it was imported to

> I have a possible update for this commit that avoids the part that
> *seems* to be problematic here. It's more verbose now, but probably also
> more readable, so, will put this up for review soon.
> But probably it still makes sense to have some up-to-date environment
> for portsnap ;)

Indeed.  I think I've fixed it by copying a newer /usr/bin/make into the
build environment -- I should be able to confirm whether it works soon.

Colin Percival
FreeBSD Deputy Release Engineer & EC2 platform maintainer
Founder, Tarsnap | | Online backups for the truly paranoid