Re: Bind 9.16.17 update built for packages?

From: Mathieu Arnold <mat_at_freebsd.org>
Date: Mon, 21 Jun 2021 08:56:17 +0200
On Mon, Jun 21, 2021 at 07:46:50AM +0800, Simon Wright wrote:
> Hi Mat and all,
> 
> ISC released a warning not to upgrade to versions 9.16.17 or 9.17.14
> which Xavier Humbert forwarded to ports_at_ on 18 June due a bug in the
> code (mail attached):
> 
> This morning I saw that the package build servers have completed a build
> using ports tree hash 7e413d93a62 and poudriere has built bind-9.16.17
> and bind-tools-9.16.17 for distribution which is the version warned about.
> 
> This bug has been corrected in 9.16.18
> https://bind9.readthedocs.io/en/v9_16/notes.html#notes-for-bind-9-16-18.
> Shouldn't 9.16.17 have been skipped and these ports moved straight to
> 9.16.18?

Well, if I had been able to see into the future and know that, when I
updated to 9.16.17, it was a bad idea, I would probably not have done it.

Hindsight is great, but, well...

-- 
Mathieu Arnold

Received on Mon Jun 21 2021 - 06:56:17 UTC

Original text of this message