Re: XFCE4 No Longer Displaying 3rd-Party Fonts.

From: Janky Jay, III <>
Date: Tue, 13 Jul 2021 14:04:28 UTC
Hi Guido,

On 7/13/21 1:32 AM, Guido Falsi via freebsd-ports wrote:
> On 12/07/21 16:49, Janky Jay, III wrote:
>> Hi All,
>>      So, I'm unsure if this is where this should go, but it did happen
>> after a recent port (pkg) upgrade of a FreeBSD 13.0 desktop system that
>> I've been running. I'd moved from "quarterly" to "latest" and got the
>> updates and now my XFCE4 desktop doesn't display any of the fonts I was
>> previously using. I only have the three basic fonts options of "Dejavu",
>> "Luxi", and "Monospace."
>>      I did come across a post on the forums [1] that appears to be the
>> exact situation that I'm seeing. However, that topic was labeled as
>> "Solved" but I don't see any actual resolution to the problem. From the
>> sound of it, their Terminus font didn't work in XFCE4 nor in Fluxbox so
>> they used something else and it did work? If that's the case, I don't
>> really see that as a "fix."
> I'm not a fonts expert and for UI I usually just stick to the
> defaults, so I'm not sure I can help much here, anyway:
    Quite alright. I appreciate the reply!

> Where exactly are you missing the extra fonts? I just made a quick
> test (on my FreeBSD 14 machine running xfce from latest) and in
> mousepad (xfce text editor) I see various fonts in the list (serto,
> caladea, carlito, Liberation) and can choose those. Maybe I'm checking
> the wrong place?
    I first noticed the missing fonts when I opened my xfce4-terminal
which as previously using an Artwiz font. When I tried to set it back to
that font after the upgrade, it was no longer a choice. After that,
looking in the XFCE4 settings, there are also only the same three fonts
to choose from for any system font.

    When I open Mousepad, there are a couple additional fonts (that must
come with the application?) such as Sans, Serif and Serto but, again, no
other fonts such as the Artwiz, Terminus, Caladea, Liberation, etc...

> Have you tried forcing reinstallation of the fonts packages on your
> system? maybe some caching was lost, reinstalling the package would
> force rebuilding the font caches.
    I have! I've tried reinstalling the packages for some of the fonts
and I've also manually placed the fonts into my ~/.fonts directory and
re-ran "fc-cache" (which shows the font added) but I continue to get the
same results.

> I also see various suggestions to add paths to xorg.conf or
> xorg.conf.d Do you have any? I think modern xorg does not need those
> and does a pretty good job at autodetecting fonts, such lines could
> actually confuse it.
    So far, I have:

  * Re-installed all fonts.
  * Added the font paths to the "Files" section in the xorg.conf file.
  * Created a new fonts.conf file in the ${LOCALBASE}/etc/xorg.conf.d
    directory with the paths to the files.
  * Made sure the "70-yes-bitmaps.conf" symlink existed in
  * Placed the fonts into my ~/.fonts directory, ran
    mkfontdir/mkfontscale and re-ran "fc-cache -v -f"
  * Placed the fonts into one of the many directories in
    /usr/local/share/fonts/* and re-ran "fc-cache"
  * Checked the Xorg.0.log to verify font paths are being picked up
    (they are)
  * Installed and ran "xfontsel" to see if I could search for the fonts
    and verify they were installed and picked up by X (they are)
  * Created an ~/.xsession file and entered commands using "xset +fp
    /paths" to add the fonts after login

    All of the above had lead to nothing thus far. I'm absolutely
stumped as to why I'm unable to use any of my installed fonts in XFCE4

    Thanks again for the reply, Guido!

Janky Jay, III