Re: XFCE4 No Longer Displaying 3rd-Party Fonts.

From: Guido Falsi via freebsd-ports <>
Date: Tue, 13 Jul 2021 07:32:43 UTC
On 12/07/21 16:49, Janky Jay, III wrote:
> Hi All,
>      So, I'm unsure if this is where this should go, but it did happen
> after a recent port (pkg) upgrade of a FreeBSD 13.0 desktop system that
> I've been running. I'd moved from "quarterly" to "latest" and got the
> updates and now my XFCE4 desktop doesn't display any of the fonts I was
> previously using. I only have the three basic fonts options of "Dejavu",
> "Luxi", and "Monospace."
>      I did come across a post on the forums [1] that appears to be the
> exact situation that I'm seeing. However, that topic was labeled as
> "Solved" but I don't see any actual resolution to the problem. From the
> sound of it, their Terminus font didn't work in XFCE4 nor in Fluxbox so
> they used something else and it did work? If that's the case, I don't
> really see that as a "fix."

I'm not a fonts expert and for UI I usually just stick to the defaults, 
so I'm not sure I can help much here, anyway:

Where exactly are you missing the extra fonts? I just made a quick test 
(on my FreeBSD 14 machine running xfce from latest) and in mousepad 
(xfce text editor) I see various fonts in the list (serto, caladea, 
carlito, Liberation) and can choose those. Maybe I'm checking the wrong 

Have you tried forcing reinstallation of the fonts packages on your 
system? maybe some caching was lost, reinstalling the package would 
force rebuilding the font caches.

I also see various suggestions to add paths to xorg.conf or xorg.conf.d 
Do you have any? I think modern xorg does not need those and does a 
pretty good job at autodetecting fonts, such lines could actually 
confuse it.

Guido Falsi <>