Re: inject IGNORE_OSVERSION in poudriere?

From: Ronald Klop <ronald-lists_at_klop.ws>
Date: Mon, 12 Jul 2021 12:07:39 +0000 (UTC)
Hi,

Thanks for your answer. Tried it before and tried it again now.
Unfortunately it doesn't work.
It is shown in the "make env" output in poudriere, but somehow it does not make it to the "pkg-static add" command in /usr/ports/Mk/Scripts/do-depends.sh.

The stack is like this. Currently running example, it is not the exact stack of the problem I have.
43999  -  SJ       0:00.83 | |       `-- /usr/local/libexec/poudriere/sh -e /usr/local/share/poudriere/bulk.sh -j freebsd13 -p custom -f /usr/local/etc/poudriere.d/port-list
44270  -  SJ       0:00.68 | |         |-- /usr/local/libexec/poudriere/sh -e /usr/local/share/poudriere/bulk.sh -j freebsd13 -p custom -f /usr/local/etc/poudriere.d/port-list
48538  -  RJ       0:00.00 | |         | `-- /usr/local/libexec/poudriere/sh -e /usr/local/share/poudriere/bulk.sh -j freebsd13 -p custom -f /usr/local/etc/poudriere.d/port-list
48198  -  SJ       0:00.00 | |         |-- /usr/local/libexec/poudriere/sh -e /usr/local/share/poudriere/bulk.sh -j freebsd13 -p custom -f /usr/local/etc/poudriere.d/port-list
48205  -  SJ       0:00.03 | |         |-- sh: poudriere[freebsd13-custom][01]: build_pkg (py38-future-0.18.2) (sh)
48214  -  SJ       0:00.01 | |         | |-- timestamp
48337  -  SJ       0:00.04 | |         | `-- /usr/bin/make -C /usr/ports/devel/py-future FLAVOR=py38 pkg-depends
48342  -  SJ       0:00.02 | |         |   `-- /bin/sh /usr/ports/Mk/Scripts/do-depends.sh
48495  -  SJ       0:00.00 | |         |     `-- /wrkdirs/usr/ports/devel/py-future/work-py38/pkg-static add /packages/All/pkg-1.16.3.txz
48496  -  RJ       0:01.11 | |         |       `-- /wrkdirs/usr/ports/devel/py-future/work-py38/pkg-static add /packages/All/pkg-1.16.3.txz

Regards,
Ronald.
 
Van: Robert Clausecker <fuz_at_fuz.su>
Datum: maandag, 12 juli 2021 11:12
Aan: ports_at_freebsd.org
Onderwerp: Re: inject IGNORE_OSVERSION in poudriere?
> 
> Hi Ronald,
> 
> Refer to poudriere(8) “Create optional make.conf.”  You should
> be able to create a file
> 
>     /usr/local/etc/poudriere.d/$jailname-make.conf
> 
> with extra make variables for $jailname.
> 
> Yours,
> Robert Clausecker
> 
> Am Mon, Jul 12, 2021 at 11:07:03AM +0000 schrieb Ronald Klop:
> > Hi,
> >
> > To save time I sometimes get pkgs from the official pkg builders and save them in the poudriere dir.
> > But now and then I get this:
> >
> > [00:00:47] ===>   Installing existing package /packages/All/llvm11-11.0.1.txz
> > [00:00:48] [freebsd14-custom-job-01] Installing llvm11-11.0.1...
> > [00:00:48] Newer FreeBSD version for package llvm11:
> > [00:00:48] To ignore this error set IGNORE_OSVERSION=yes
> > [00:00:48] - package: 1400025
> > [00:00:48] - running kernel: 1400024
> > [00:00:48] Ignore the mismatch and continue? [y/N]:
> > [00:00:49] Failed to install the following 1 package(s): /packages/All/llvm11-11.0.1.txz
> > [00:00:49] *** Error code 1
> >
> > Normally I delete/create the poudriere jail, but the upstream world used by poudriere is not new enough yet.
> >
> > How can I set IGNORE_OSVERSION=yes in the poudriere environment?
> >
> > Regards,
> > Ronald.
> 
> -- 
> ()  ascii ribbon campaign - for an 8-bit clean world
> /\  - against html email  - against proprietary attachments
>  
> 
> 
> 
Received on Mon Jul 12 2021 - 12:07:39 UTC

Original text of this message