Re: Can not build kernel on 1GB VM *Solved*

From: Tijl Coosemans <>
Date: Wed, 20 Apr 2022 09:12:29 UTC
On Mon, 18 Apr 2022 13:33:33 -0400 Michael Wayne <>
> On Fri, Apr 15, 2022 at 01:49:53PM -0400, Michael Wayne wrote:
>> I have a VM with 1GB RAM running FreeBSD 12.1-RELEASE-p3
>> I'm trying to upgrade the machine to 12.3 and having swap failures.  
> I tried a number of things, all of which failed.
> Since the offending line is:
>>    ctfmerge -L VERSION -g -o kernel.full ...  
> I went digging through makefiles and found:
>    MK_CTF=no
> Adding this to the command line permitted the build to complete and
> the machine is now running on the new kernel. Hopefully this helps
> others. I'm still not sure why the kernel refused to use swap but 
> this is a very easy to duplicate issue.

How many CPU cores does the VM have?

Can you still reproduce it now that you run 12.3?

If so, can you try the attached patch?  It prevents background
laundering when nfreed == 0, restoring some behaviour from before and