[Bug 256072] www/firefox: requires COMPAT_FREEBSD11

From: <bugzilla-noreply_at_freebsd.org>
Date: Sat, 22 May 2021 11:55:42 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=256072

Jan Beich <jbeich_at_FreeBSD.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
              Flags|maintainer-feedback?(gecko_at_ |maintainer-feedback+
                   |FreeBSD.org)                |

--- Comment #5 from Jan Beich <jbeich_at_FreeBSD.org> ---
See https://github.com/rust-lang/libc/issues/570

www/firefox uses libc crate which due to lack of OS version in --target triple
binds to symbols from the oldest still supported FreeBSD major version. After
FreeBSD 11.* reaches EOL on 2021-09-30 upstream may bump the default from
relying on COMPAT_FREEBSD11 to COMPAT_FREEBSD12. Also, if LIBC_CI is defined
via environ(7) libc crate would use freebsd-version(1) to try binding natively
but it doesn't support 14.0-CURRENT yet.

https://searchfox.org/mozilla-release/rev/a8d49c009a9250de34d683567d586f3aeb409b4c/third_party/rust/libc/build.rs#33

-- 
You are receiving this mail because:
You are the assignee for the bug.
Received on Sat May 22 2021 - 11:55:42 UTC

Original text of this message