Re: boot hangs after installworld at FreeBSD 14.0-CURRENT main-n248198-72f7ddb587a

From: Warner Losh <imp_at_bsdimp.com>
Date: Sun, 25 Jul 2021 09:54:35 -0600
On Sun, Jul 25, 2021 at 3:30 AM Gary Jennejohn <gljennjohn_at_gmail.com> wrote:

> I updated my FBSD-14 tree yesterday.
>
> uname -a shows FreeBSD 14.0-CURRENT #5 main-n248198-72f7ddb587a.
>
> Did a buildkernel and a clean buildworld yesterday.
>
> This morning I booted the new kernel, did an installworld and rebooted
> the new kernel.
>
> Or, should I say, I tried to reboot the new kernel.
>
> During boot I see the following outptut:
>
> loading /boot/defaults/loader.conf
> /
>
> and the boot hangs.
>
> The second line should have contained
> /boot/test/kernel (I always install new kernels to /boot/test)
>
> followed by lines containing the various modules which get loaded.
>
> Luckily, I had a USB thumb drive with a FreeBSD memstick.img AND a
> complete backup of the old /boot, so I could boot from the thumb
> drive and restore /boot (but I moved /boot to /boot.bad before I
> did that just in case).  With the restored (old) /boot everything
> works.
>

Little has changed in the boot loader. Do you know the hash that worked? Or
if I misread above, the has that failed?

Warner

Note that I use the 4th boot stuff and EFI is disabled in my BIOS.
>
> I don't know just what is failing in the new boot binaries, but
> sum shows that quite a few of them have changed.
>
> As an aside I see the installation of armv8crypto.4.gz fail every time
> I run installworld because make wants to put it under
> /usr/share/man/cat4/aarch64, which doesn't exist.  I got tired of
> having to fix that and restart the installworld and simply created
> that directory.  Note that I always copy the contents of
> /usr/src/etc/mtree to /etc/mtree before doing installworld, so mtree
> should have created the missing directory if it were required.
>
> --
> Gary Jennejohn
>
>
Received on Sun Jul 25 2021 - 15:54:35 UTC

Original text of this message