[Bug 270707] Installer media doesn't boot on Thinkpad T14s Gen 3 (Ryzen 7 Pro 6850U)

From: <bugzilla-noreply_at_freebsd.org>
Date: Sat, 08 Apr 2023 16:05:49 UTC

            Bug ID: 270707
           Summary: Installer media doesn't boot on Thinkpad T14s Gen 3
                    (Ryzen 7 Pro 6850U)
           Product: Base System
           Version: 13.2-RELEASE
          Hardware: amd64
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: kern
          Assignee: bugs@FreeBSD.org
          Reporter: aixdroix_OSS@protonmail.com

Created attachment 241356
  --> https://bugs.freebsd.org/bugzilla/attachment.cgi?id=241356&action=edit
Boot process log, multi-user

Filing this bug report as I was advised to do so on IRC channel. 

Tried booting the Thinkpad T14s Gen 3 (Ryzen 7 Pro 6850U) using 13.1, 13.2 and
14.0 installation medias (USB) (Selected 13.2 for this report as it's the
latest release version). The booting process gets stuck on (fans continue to

acpi_acad0: <AC Adapter> on acpi0

line. See the attached picture for more detail. With the verbose option
enabled, the last line I see is `AcpiOsExecute: task queue not started` I've
tried the latest BIOS driver from Lenovo, and an older version to see if that's
the source of the problem, but I've got the same result. To rule out "defective
laptop" case; I've obtained another T14S Gen 3 with 6850U and it displayed the
same behavior. Also tried while on battery/AC Power; no difference.

I can test patches if needed.

You are receiving this mail because:
You are the assignee for the bug.