[Bug 264723] the KERN_LOCKF sysctl returns kl_file_fsid that doesn't match st_dev from stat()

From: <bugzilla-noreply_at_freebsd.org>
Date: Fri, 17 Jun 2022 18:49:47 UTC

--- Comment #5 from Damjan Jovanovic <damjan.jov@gmail.com> ---
"fsid" is widely used as the name for dev_t fields in sys/user.h: struct
kinfo_file, struct kinfo_ovmentry, struct kinfo_vmentry, and struct
kinfo_vmobject use it.

I don't think we should rename. We are not changing the meaning of the field,
we're changing a meaningless field to meaningful field. Code can only break if
it relies on meaningful values, but currently kl_file_fsid is meaningless,
almost like an uninitialized variable. And it's only in CURRENT, so it can
freely change.

You are receiving this mail because:
You are the assignee for the bug.