[Bug 257033] top(1): Sort by PID broke in 13.0-RELEASE

From: <bugzilla-noreply_at_freebsd.org>
Date: Tue, 06 Jul 2021 21:07:02 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=257033

            Bug ID: 257033
           Summary: top(1): Sort by PID broke in 13.0-RELEASE
           Product: Base System
           Version: 13.0-RELEASE
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: bin
          Assignee: bugs_at_FreeBSD.org
          Reporter: kevinz5000_at_gmail.com

Sorting processes by PID broke in 13.0-RELEASE.

My uname:
13.0-RELEASE-p3 FreeBSD 13.0-RELEASE-p3 #0: Tue Jun 29 19:46:20 UTC 2021    
root_at_amd64-builder.daemonology.net:/usr/obj/usr/src/amd64.amd64/sys/GENERIC 
amd64

Steps to reproduce:
1. Run 'top'
2. Press 'O', then type 'pid' <ENTER>

top(1) sorts processes correctly on 12.2-RELEASE.

I tried to bisect the issue by building top from as far back as
3be6ef06596a345558f15b91721a9021f3aeefba (May 19 2018) and running on
13.0-RELEASE, but the issue persists. I have not yet tried bisecting further
back.

-- 
You are receiving this mail because:
You are the assignee for the bug.
Received on Tue Jul 06 2021 - 21:07:02 UTC

Original text of this message