After upgrading to 7.3, settings in xorg.conf are not obeyed

Andy Fawcett andy at
Wed Sep 19 03:47:08 PDT 2007


Yesterday I upgraded my ports to include the xorg 7.3

After restarting, xorg ignored any settings in my xorg.conf to use 
1600x1200 as my desktop resolution, and chose a much lower resolution 
(1152 by something, can't recall exactly).

I tried for several hours to get the right resolution, including forcing 
options to ignore EDID/DDC info, and in the end I put back 7.2 from 
packages and it all worked correctly again.

I'm using the ati driver, hardware is 

drm0 at pci1:0:0:  class=0x030000 card=0x7c20174b chip=0x41511002 rev=0x00 
    vendor     = 'ATI Technologies Inc'
    device     = 'Radeon 9600 (RV350)'
    class      = display
    subclass   = VGA

with a CRT on the 15 pin connector (through a KVM, but same happens with 
direct connection).

Unfortunately I don't have logfiles available at the moment, and I won't 
be able to check further before the weekend.

Please cc me on any responses, I am not on the list.



More information about the freebsd-x11 mailing list