mysql crashes on 5.3-stable, SMP, linuxthreads

Billy Newsom smartweb at
Sat Jan 1 18:17:09 PST 2005

I have just built a FreeBSD 5.3 box with SMP enabled on a dual processor 
machine.  I kept having a lot of crashes at some point in the install, and I 
believe I now have the cuprit: mysql-server-4.1.7 is doing it.   Lately, when 
mysql-server is running under no load, it caused lockups of the system, with 
no core dumps.

I have been frantically trying to re-install a lot of things -- I did a cvsup 
on the stable tree, recompiled the source, and tried a generic kernel with no 
SMP.  I reinstalled a lot of ports that could have been doing this. 
Meanwhile, a lot of things were dumping core.  I tried cooling the CPU and 
memory just in case it was hardware-related.

Finally, I now have a stable computer, running in SMP, but only if 
mysql-server is disabled.  Does anyone know what sort of things I can do to 
get mysql to run?  I am in the middle of another recompile of the same 
mysql-server with the same options (I believe they are openssl, linuxthreads, 
and optimize) as before.  Has anyone seen this problem before?  I will report 
back tomorrow if a "simple" reinstall of the port has fixed this issue, but I 
have reinstalled it thrice now.


More information about the freebsd-stable mailing list