5.x packages temporarily broken (Re: Circles with libcrypt.so.3)

Kris Kennaway kris at obsecurity.org
Fri Aug 26 21:39:57 GMT 2005

On Fri, Aug 26, 2005 at 04:21:07PM -0500, Scot Hetzel wrote:
> On 8/26/05, fbsd <fbsd at sefao.com> wrote:
> > Hello,
> > 
> > I am trying to install Apache+Mod_ssl via the package apache+mod_ssl-1.3.33+2.8.22_1.tbz on a base 5.4 install, I installed in the following order:
> > libtool-1.5.18.tbz
> > expat-1.95.8_3.tbz
> > mm-1.3.1.tgz
> > rc_subr-1.31_1.tbz
> > apache+ssl-
> > 
> > All installed with pkg_add with no issues.  Then I tried to start Apache, it complained as follows:
> > /libexec/ld-elf.so.1: Shared Object "libcrypt.so.3" not found, required by Apache.
> > 
> > There is no "libcrypt.so.3" file on any of my FreeBSD 5.4 systems nor on the CDROM..?
> :
> > So since this is not a production machine yet I try pkg_delete -f perl5.8.6, it does not see the package. So finally I use pkg_add -f perl5.8.7.  It complains that I am missing (so far) via /libexec/ld-elf.so.1: Shared Object:
> > libcrypt.so.3 (as well)
> > libutil.so.5
> > libthread.so.2
> > not found, required by perl5.8.7...
> > 
> > What am I missing?  I would prefer not to start over. From the 5.4 install, should I just install Apache and Mod_SSL from source? Would I run into the same issues?
> > 
> You'll need to install all 5-STABLE packages from source, as I just
> helped another user with a similar problem (no libpthread.so.2 for his
> net/ntop package).  I suspect that the build system for 5-STABLE
> packages is broken, as those library versions are for RELENG_6 and
> 7.0-CURRENT.
> Another possibility is that the package build for RELENG_6 is placing
> the packages in the wrong directory.

Somehow a 6.0 package set got spammed into the 5.x package directory.
I don't know for certain whose fault this was, but I'm in the process
of uploading a new 5.x package set which should propagate out over the
next 24 hours or so.  Sorry for the breakage.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-stable/attachments/20050826/baaba6af/attachment.bin

More information about the freebsd-stable mailing list