USB Keyboard & Video Corruption w/ Cups (again)

Jeff Molofee nehe at
Sat Mar 18 19:17:43 UTC 2006

I bought an Eclipse keyboard a few weeks ago, and have not had any luck 
getting the media keys to work on it. Is this a problem with USB 
keyboard? I noticed on my micro$oft digital media pro keyboard that the 
media keys would not work in usb mode, but if I put the ps2 adapter on 
they did work. In short, has anyone gotten the eclipse to work without 
the adapter.

Another problem I have asked about many time in this list is with cups 
and webmin. If I enable either of these in rc.conf the next time I boot, 
and they start up, the top of my screen is filled with random graphical 
garbage. As I move my mouse I see random pixels at the top of the 
screen. The pixels update randomly depending on where my mouse is. I 
have tried to describe the problem with text (showing a screen and 
random characters to illustrate the random pixels), but this time I am 
going to attempt to include a screenshot (not sure what the policy is on 
screenshots). If I disable cups or webmin, the problem goes away. This 
problem did not happen when I initially installed 6.x.

Currently I am running latest 6.x, I have an nvidia 5900fx using the 
nvidia driver. I am running in 1280x1024, although res and bit depth 
don't seem to matter in regards to the video corruption, all ports were 
installed via source. I have tried reinstalling ports and os from scratch.

More information about the freebsd-questions mailing list