more problems with 5.3 and "TIMEOUT - WRITE_DMA"

Mike Daemon mike.daemon at
Sun Mar 27 13:47:21 PST 2005

On Sun, 27 Mar 2005 13:32:43 -0800, Thomas Foster <tbonius at> wrote:
> I had this same issue

I´ll have seen some more posts on the list with about the same problem
therefore, I hope some bright one will take alook at the code.. and
post something smart.. I´m very much stuck, hopeing any new snapshot
will work..

 on an older AMD Nforce board.  5.2.1 seemed to install
> and run.. but moving to 5.3 gave me issues.  I tinkered with the DMA
> settings in the BIOS.. to no avail.  The Geometry seemed to be off on the
> drive I noticed (IBM deskstar) when I newfs'd it.. so I changed out drives..
> but never got it working..  I eventually just dropped Gentoo on it.
> What chipset, drive controller hard drive are you using on this system?

I´ll notised that my idecontroller IS supported by the ata-driver,
witch makes it even stranger.. (I think I will check on my cabling
once more, even if it´s a newly installed _rounded_ 32 pin cable..)

My atacontroller: SiS 5513
My HDD: Seagate 200 GB

> T
> ----- Original Message -----
> From: "Mike Daemon" <mike.daemon at>
> To: "FreeBSD Questions" <freebsd-questions at>
> Sent: Sunday, March 27, 2005 1:15 PM
> Subject: more problems with 5.3 and "TIMEOUT - WRITE_DMA"
> I got this annoying problem when upgradeing to 5.3, the miniinst iso
> blurps out "TIMEOUT - WRITE_DMA" when it starts writing base to my
> disk. And when I tried to first install 5.2.1 and upgrade (cvsup, make
> buildworld etc.. ) to 5.3 that way everything seems fine until I
> reboot to single-user-mode, as soon as Im starting to write anything
> to the disk it´s blurping out those errors.. I have diagnosticed my
> disk, checked my cabling and fixed my PSU (installed a brand new one).
> No difference. I noticed that my ide-controller was supported in 4.11,
> but not? in 5.3, is that realy true? seems very strange...
> Sence I duel boot with Wintendo/Lunix and don´t see this problem with
> those oses I´m very confused of what to do next..
> I´ll tried some snapshots to but no luck...
> / Mike
> ps My dmesg goes in the attachment, in hope for a patch/solution to
> this problem. ds
> --------------------------------------------------------------------------------
> > _______________________________________________
> > freebsd-questions at mailing list
> >
> > To unsubscribe, send any mail to
> > "freebsd-questions-unsubscribe at"
> >

More information about the freebsd-questions mailing list