AWSTATS Error & Resolution

Matthew Seaman m.seaman at
Wed Jun 9 03:55:59 PDT 2004

On Tue, Jun 08, 2004 at 03:35:36PM -0700, Drew Tomlinson wrote:
> After upgrading perl from 5.8.2 to 5.8.4, following the instructions in 
> /usr/ports/UPDATING, I found awstats-6.0_1 no longer worked.  I ran 
> interactively and received the following error:
> Bizarre copy of ARRAY in aassign at /path/to/ line 8707
> After some checking, I found this issue was fixed in revision 
> 1.747.  I downloaded the most current revision (1.755) and replaced the 
> revision that's included with the port.  This seems to solve the 
> problem.  YMMV.
> Is it appropriate to send a problem report about this?  I've never sent 
> one so I want to be sure before bugging someone.
> Hopefully this post will save others from having to research and resolve 
> this issue.

You aren't the only one to notice this: it's being discussed over on
freebsd-ports at ... at the moment.  See the thread that starts with:

which generally means a fix will soon be forthcoming.

Generally in these sort of cases your first point of contact should be
the port's maintainer.  Find that by:

    % cd /usr/ports/www/awstats
    % make -V MAINTAINER

Now just sending an e-mail to the maintainer usually suffices, and
most maintainers will be happy to fix things and help you out

However, if the maintainer has an address (including
various mailing list addresses like x11 at, perl at,
ports at then you can use send-pr(1) to send in a bug report
- preferably including a fix. If the port is unmaintained
(ie. maintainer is ports at then you may well get asked to
become the maintainer...  Also use send-pr(1) if e-mail to the
maintainer bounces or you get no reply after a reasonable time
(ie. two weeks) -- mention the problem in the PR you send.  See



Dr Matthew J Seaman MA, D.Phil.                       26 The Paddocks
                                                      Savill Way
PGP:         Marlow
Tel: +44 1628 476614                                  Bucks., SL7 1TH UK
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-questions mailing list