Ports : Mozilla / Mozilla-devel

Dan Nelson dnelson at allantgroup.com
Tue Sep 30 09:23:45 PDT 2003

In the last episode (Sep 30), Mike Hogsett said:
> I have been pulling my hair out over this.  I installed a package
> several days ago that required gettext.  The gettext in ports has
> been updated so I had to deinstall the existing on and install the
> version from ports.
> After that mozilla and mozilla-devel (and some other stuff) wont run
> becuase libintl.so.4 no longer exists. (gettext from ports installs
> libintl.so.5 now).
> I pkg_delete'd mozilla and mozilla-devel and rebuilt (have tried
> both) but even after they build and install they are still asking for
> libintl.so.4!!

They may be linking against a shared library that requires

> I rm -rf'd /usr/ports and cvsup'd back hoping to clear any cruft that
> may have remained and rebuilt mozilla-devel, still no dice!
> Anyone have a suggestion how I can get either of these ports to work
> again?

At this point, you'll probably have to rebuild all the ports that
depended on the old gettext.  The portupgrade tools minimize this risk
by preserving old shlibs in /usr/local/lib/compat/pkg, so you can
upgrade dependant ports at your leisure.

	Dan Nelson
	dnelson at allantgroup.com

More information about the freebsd-questions mailing list