jboss5 start/stop not working SOLVED

Horst Leitenmueller horst.leitenmueller at liwest.at
Sun May 2 09:35:07 UTC 2010

solved my own problem,

if ps -faux is not showing org.jboss.Main (only [java])
its because of the 
kern.ps_arg_cache_limit: 256  which is to less if you have a lot of
vmwargs for the jboss/or java app

therefore set at least to 
sysctl kern.ps_arg_cache_limit=1024
kern.ps_arg_cache_limit: 256 -> 1024

in the base system of the freebsd / in the jail its also set (if you try
to set in the jail you get an Operation not permitted exception)

NOW the pgrep detects the org.jboss.Main and pid is correct written =>
start and stop is working...

thanx for help ;-)


On Sun, 2010-05-02 at 11:08 +0200, Horst Leitenmueller wrote:
> hello,
> i have a question on jboss5 port ver 5.1 the start/stop is not working,
> the pidfile is not written correct because the 
> pgrep -U www -f org.jboss.Main does not find anything...
> my system freebsd 7.2 diablo jdk 1.6
> with ps -faux i see
> :
> 11433  ??  IJ     2:44.49 [java]    // this is the jboss running
> add info: all is running inside a jail!!
> how could i fix / or could it be fixed?
> thanx for answer
> br horst
> Same sent to freebsd forum, but no reply till
> now...http://forums.freebsd.org/showthread.php?t=11018&highlight=jboss5
> _______________________________________________
> freebsd-java at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-java
> To unsubscribe, send any mail to "freebsd-java-unsubscribe at freebsd.org"

More information about the freebsd-java mailing list