Java JDK 1.6p4 and Azureus

Joe Kelsey joe at
Sun Feb 24 02:22:54 UTC 2008

Joe Kelsey wrote:
> --- Daniel Engberg <diizzyy at> wrote:
>>> Hi,
>>> I browsed earlier archives and found someone who had similar issues.
>>> What happens is that Azureus starts fine, adds torrents without any 
>>> errors, connects to a few peers/seeders and then idles. It doesnt
>>> fetch any pieces or gives any errors.
>>> I've tried the diablo packages/ports (1.5 and 1.6) without any
>>> success, and the older patchset 3 with the same result. Does anyone 
>>> know a workaround? In case anyone is wondering I'm running the 
>>> CLI/WebUI interface(s).
> Azureus experiences the typical Java problem.  I could not get 
> anything to happen for quite some time until I realized that the Java 
> runtime was spending all of its time waiting for something to happen 
> in the IPv6 connections it was trying to open.  I had to completely 
> remove IPv6 from the kernel.  Once I did that, Azureus magically 
> started working.
> There is something major broken in the Java runtime hwich causes 
> everything to stop whenever you try to open an IPv6 connection.  
> Remove IPV6 from the kernel, and everything works.  When and if you 
> ever get real IPv6 connections in your machine, things might actualy 
> work.  For now, just remove it and move on.
Two different people have responded personally to me alone about 
different ways to get Java to try v4 connections instead of v6 
connections.  This is completely irrelevant.  There is still something 
broken in the Java runtime which spends all of its time in v6 connection 
hell unless you disable v6 in the kernel.  Someone needs to figure out 
why the Java runtime on FreeBSD does this.  I suspect some thing in the 
runtime or in the kernel v6 stuff that is broken, but I do not know 
where to look.


More information about the freebsd-java mailing list