[dtrace] syscall provider naming convention.
fbsdlist at src.cx
Fri Dec 24 02:02:06 UTC 2010
> I have one comment though. I am not sure about renaming syscall.ko to
You mean systrace_freebsd.ko.
I've renamed it for consistency with other systrace provider variants.
I can change it back.
> Perhaps we could keep the old name? Or add a new module
> under that name that would load native syscall module and all emulation syscall
> modules (if any)?
I'm not sure that creating an umbrella 'systrace' module is worth it.
"kldload /boot/kernel/systrace*" should do that just fine. The reason
dtrace exists is that there are number of modules with dtrace
providers that are not easily distinguishable by their name.
More information about the freebsd-current