kern/151608: [ata] FreeBSD doesn't detect Sandforce-based SSD

Thomas E. Spanjaard tgen at
Mon Oct 25 12:52:07 UTC 2010

On 10/24/2010 21:18, Alexander Motin wrote:
> Thomas E. Spanjaard wrote:
>> In an attempt to get more information about this issue, I'd like to ask
>> people on freebsd-current if they're using any Sandforce-based SSDs with
>> FreeBSD. So far, it appears not a lot of people do, making it hard to
>> debug this issue (
> MCP5x SATA are not the best controllers for compatibility testing. They
> have enough problems on their own, even without Sandforce.
> When you tested Marvell, have you tried to use mvs(4) driver?

No, I only tried to use ata(4). I tried using mvs(4) now, and that works!

mvs0: <Marvell 88SX6081 SATA controller> port 0x4000-0x40ff mem
0xb0100000-0xb01fffff irq 11 at device 2.0 on pci1
mvs0: Gen-II, 8 3Gbps ports, Port Multiplier supported
mvsch0: <Marvell SATA channel> at channel 0 on mvs0
mvsch1: <Marvell SATA channel> at channel 1 on mvs0
mvsch2: <Marvell SATA channel> at channel 2 on mvs0
mvsch3: <Marvell SATA channel> at channel 3 on mvs0
mvsch4: <Marvell SATA channel> at channel 4 on mvs0
mvsch5: <Marvell SATA channel> at channel 5 on mvs0
mvsch6: <Marvell SATA channel> at channel 6 on mvs0
mvsch7: <Marvell SATA channel> at channel 7 on mvs0

ada0 at mvsch0 bus 0 scbus0 target 0 lun 0
ada0: <OCZ-AGILITY2 3.5 1.11> ATA-8 SATA 2.x device
ada0: 300.000MB/s transfers (SATA 2.x, UDMA6, PIO 2048bytes)
ada0: Command Queueing enabled
ada0: 85857MB (175836528 512 byte sectors: 16H 63S/T 16383C)

In any case, it seems this is not squarely to blame on the nVidia SATA
controller, because ata(4) couldn't detect it either when on the Marvell
one. So the bug in ata(4) remains.

	Thomas E. Spanjaard
	tgen at
	tgen at

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 488 bytes
Desc: OpenPGP digital signature
Url :

More information about the freebsd-bugs mailing list