cvs commit: src/sys/sparc64/sparc64 vm_machdep.c

Thomas Moestl t.moestl at
Thu May 20 12:56:17 PDT 2004

On Thu, 2004/05/20 at 11:48:19 -0700, Julian Elischer wrote:
> While you are there, can you rename it to cpu_exit2()
> as it has nothing to do with the scheduler..

As I mentioned previously, the connection is that this function must
be called with sched_lock held (and it must be held until the final
cpu_throw() after that). It does tasks that have a connection to
thread switching, so the name is not really inappropriate.

cpu_exit2 is far less descriptive as a name.

	- Thomas

Thomas Moestl	<t.moestl at>
		<tmm at>
"I try to make everyone's day a little more surreal."
						-- Calvin and Hobbes

More information about the cvs-src mailing list