cvs commit: src/sys/sparc64/sparc64 vm_machdep.c
julian at elischer.org
Thu May 20 13:04:42 PDT 2004
On Thu, 20 May 2004, Thomas Moestl wrote:
> On Thu, 2004/05/20 at 11:48:19 -0700, Julian Elischer wrote:
> > While you are there, can you rename it to cpu_exit2()
> > as it has nothing to do with the scheduler..
> As I mentioned previously, the connection is that this function must
> be called with sched_lock held (and it must be held until the final
> cpu_throw() after that). It does tasks that have a connection to
> thread switching, so the name is not really inappropriate.
> cpu_exit2 is far less descriptive as a name.
but less misleading than cpu_sched_sxit()
switching is nothing to do with the scheduler..
If there is a cpu_exit() and a cpu_exit2() than one assumes that there
would be a comment at cpu_exit2() explaining why it needs to be separate
from cpu_exit(). cpu_sched_exit() just makes someone looking for
scheduler components to get a false positive, and waste time staring at
it trying to work out what the f*ck it has to do with the scheduler.
cpu_exit_schedlocked() or something would be ok (if not to verbose)
> - Thomas
> Thomas Moestl <t.moestl at tu-bs.de> http://www.tu-bs.de/~y0015675/
> <tmm at FreeBSD.org> http://people.FreeBSD.org/~tmm/
> "I try to make everyone's day a little more surreal."
> -- Calvin and Hobbes
More information about the cvs-src