PERFORCE change 75895 for review

Robert Watson rwatson at FreeBSD.org
Sun Apr 24 16:47:17 GMT 2005


http://perforce.freebsd.org/chv.cgi?CH=75895

Change 75895 by rwatson at rwatson_paprika on 2005/04/24 16:46:18

	Rename libbsm_internal.h to audit_internal.h so that the kernel can
	also use it to assemble BSM records.

Affected files ...

.. //depot/projects/trustedbsd/openbsm/bsm/Makefile#3 edit
.. //depot/projects/trustedbsd/openbsm/bsm/audit_internal.h#1 branch
.. //depot/projects/trustedbsd/openbsm/libbsm/bsm_audit.c#7 edit
.. //depot/projects/trustedbsd/openbsm/libbsm/bsm_io.c#4 edit
.. //depot/projects/trustedbsd/openbsm/libbsm/libbsm_internal.h#2 delete

Differences ...

==== //depot/projects/trustedbsd/openbsm/bsm/Makefile#3 (text+ko) ====

@@ -3,6 +3,7 @@
 #
 
 INCS=	audit.h								\
+	audit_internal.h						\
 	audit_kernel.h							\
 	audit_kevents.h							\
 	audit_record.h							\

==== //depot/projects/trustedbsd/openbsm/libbsm/bsm_audit.c#7 (text+ko) ====

@@ -31,14 +31,14 @@
 #include <sys/types.h>
 #include <sys/queue.h>
 
+#include <bsm/audit_internal.h>
+
 #include <errno.h>
 #include <libbsm.h>
 #include <pthread.h>
 #include <stdlib.h>
 #include <string.h>
 
-#include "libbsm_internal.h"
-
 /* array of used descriptors */
 static au_record_t* open_desc_table[MAX_AUDIT_RECORDS]; 
 

==== //depot/projects/trustedbsd/openbsm/libbsm/bsm_io.c#4 (text+ko) ====

@@ -40,10 +40,10 @@
 #include <pwd.h>
 #include <grp.h>
 
+#include <bsm/audit_internal.h>
+
 #include <libbsm.h>
 
-#include "libbsm_internal.h"
-
 #define READ_TOKEN_BYTES(buf, len, dest, size, bytesread, err)	\
 	do {\
 		if(bytesread + size > len) {\
To Unsubscribe: send mail to majordomo at trustedbsd.org
with "unsubscribe trustedbsd-cvs" in the body of the message



More information about the trustedbsd-cvs mailing list