svn commit: r225195 - projects/ino64/include/protocols
Matthew D Fleming
mdf at FreeBSD.org
Fri Aug 26 17:28:29 UTC 2011
Author: mdf
Date: Fri Aug 26 17:28:29 2011
New Revision: 225195
URL: http://svn.freebsd.org/changeset/base/225195
Log:
Don't use ino_t in dumprestore protocol definition.
GSoC r222842.
Code by Gleb Kurtsou.
Modified:
projects/ino64/include/protocols/dumprestore.h
Modified: projects/ino64/include/protocols/dumprestore.h
==============================================================================
--- projects/ino64/include/protocols/dumprestore.h Fri Aug 26 17:08:22 2011 (r225194)
+++ projects/ino64/include/protocols/dumprestore.h Fri Aug 26 17:28:29 2011 (r225195)
@@ -65,6 +65,15 @@
#endif
#define CHECKSUM (int)84446
+/*
+ * Since ino_t size is changing to 64-bits, yet we desire this structure to
+ * remain compatible with exiting dump formats, we do NOT use ino_t here,
+ * but rather define a 32-bit type in its place. At some point, it may be
+ * necessary to use some of the c_spare[] in order to fully support 64-bit
+ * inode numbers.
+ */
+typedef uint32_t dump_ino_t;
+
union u_spcl {
char dummy[TP_BSIZE];
struct s_spcl {
@@ -73,7 +82,7 @@ union u_spcl {
int32_t c_old_ddate; /* date of previous dump */
int32_t c_volume; /* dump volume number */
int32_t c_old_tapea; /* logical block of this record */
- ino_t c_inumber; /* number of inode */
+ dump_ino_t c_inumber; /* number of inode */
int32_t c_magic; /* magic number (see above) */
int32_t c_checksum; /* record checksum */
/*
More information about the svn-src-projects
mailing list