svn commit: r362781 - head/sys/compat/linuxkpi/common/include/linux

Warner Losh imp at bsdimp.com
Mon Jun 29 20:26:59 UTC 2020


On Mon, Jun 29, 2020, 2:15 PM Ravi Pokala <rpokala at freebsd.org> wrote:

> -----Original Message-----
> From: <owner-src-committers at freebsd.org> on behalf of Hans Petter Selasky
> <hselasky at FreeBSD.org>
> Date: 2020-06-29, Monday at 06:08
> To: <src-committers at freebsd.org>, <svn-src-all at freebsd.org>, <
> svn-src-head at freebsd.org>
> Subject: svn commit: r362781 -
> head/sys/compat/linuxkpi/common/include/linux
>
>     Author: hselasky
>     Date: Mon Jun 29 13:08:40 2020
>     New Revision: 362781
>     URL: https://svnweb.freebsd.org/changeset/base/362781
>
>     Log:
>       Implement is_signed(), type_max() and type_min() function macros in
> the
>       LinuxKPI.
>
>       MFC after:        1 week
>       Sponsored by:     Mellanox Technologies
>
>     Modified:
>       head/sys/compat/linuxkpi/common/include/linux/kernel.h
>
>     Modified: head/sys/compat/linuxkpi/common/include/linux/kernel.h
>
> ==============================================================================
>     --- head/sys/compat/linuxkpi/common/include/linux/kernel.h  Mon Jun 29
> 12:59:09 2020        (r362780)
>     +++ head/sys/compat/linuxkpi/common/include/linux/kernel.h  Mon Jun 29
> 13:08:40 2020        (r362781)
>     @@ -564,4 +564,20 @@ linux_ratelimited(linux_ratelimit_t *rl)
>      #define    __is_constexpr(x) \
>         __builtin_constant_p(x)
>
> Hi Hans,
>
>     +#define            is_signed(x) (((x)-1 / (x)2) == (x)0)
>
> It took me several reads to understand this, until I figured out that 'x'
> is not a variable, it's the name of a *type*.
>
> If 'x' is a variable, then '(x)-1' is subtraction, but '(x)2' and '(x)0'
> are nonsensical.
>
> If 'x' is a *type*, then '(x)-1' is typecasting '-1', and similarly for
> '(x)2' and '(x)0'.
>
> So, perhaps a comment, or a better name for 'x'?
>

I had similar thoughts. Maybe 't' instead?

Warner

Thanks,
>
> Ravi (rpokala@)
>
>     +#define            type_max(x) (
>      \
>     +  (sizeof(x) >= 8) ? (is_signed(x) ? INT64_MAX : UINT64_MAX) :     \
>     +  (sizeof(x) >= 4) ? (is_signed(x) ? INT32_MAX : UINT32_MAX) :     \
>     +  (sizeof(x) >= 2) ? (is_signed(x) ? INT16_MAX : UINT16_MAX) :     \
>     +                (is_signed(x) ? INT8_MAX : UINT8_MAX)      \
>     +)
>     +
>     +#define            type_min(x) (                                   \
>     +  (sizeof(x) >= 8) ? (is_signed(x) ? INT64_MIN : 0) :      \
>     +  (sizeof(x) >= 4) ? (is_signed(x) ? INT32_MIN : 0) :      \
>     +  (sizeof(x) >= 2) ? (is_signed(x) ? INT16_MIN : 0) :      \
>     +                (is_signed(x) ? INT8_MIN : 0)      \
>     +)
>     +
>      #endif     /* _LINUX_KERNEL_H_ */
>
>
>


More information about the svn-src-head mailing list