svn commit: r349115 - in head/sys: arm/allwinner dev/pwm

Ian Lepore ian at FreeBSD.org
Sun Jun 16 15:57:02 UTC 2019


Author: ian
Date: Sun Jun 16 15:56:59 2019
New Revision: 349115
URL: https://svnweb.freebsd.org/changeset/base/349115

Log:
  Rename pwmbus.h to ofw_pwm.h, because after all the recent changes, there
  is nothing left in the file that related to pwmbus at all.  It just contains
  prototypes for the functions implemented in dev/pwm.ofw_pwm.c, so name it
  accordingly and fix the include protect wrappers to match.
  
  A new pwmbus.h will be coming along in a future commit.

Added:
  head/sys/dev/pwm/ofw_pwm.h
     - copied, changed from r349114, head/sys/dev/pwm/pwmbus.h
Deleted:
  head/sys/dev/pwm/pwmbus.h
Modified:
  head/sys/arm/allwinner/aw_pwm.c
  head/sys/dev/pwm/ofw_pwm.c
  head/sys/dev/pwm/pwmbus.c

Modified: head/sys/arm/allwinner/aw_pwm.c
==============================================================================
--- head/sys/arm/allwinner/aw_pwm.c	Sun Jun 16 15:34:10 2019	(r349114)
+++ head/sys/arm/allwinner/aw_pwm.c	Sun Jun 16 15:56:59 2019	(r349115)
@@ -44,8 +44,6 @@ __FBSDID("$FreeBSD$");
 
 #include <dev/extres/clk/clk.h>
 
-#include <dev/pwm/pwmbus.h>
-
 #include "pwmbus_if.h"
 
 #define	AW_PWM_CTRL			0x00

Modified: head/sys/dev/pwm/ofw_pwm.c
==============================================================================
--- head/sys/dev/pwm/ofw_pwm.c	Sun Jun 16 15:34:10 2019	(r349114)
+++ head/sys/dev/pwm/ofw_pwm.c	Sun Jun 16 15:56:59 2019	(r349115)
@@ -38,9 +38,7 @@ __FBSDID("$FreeBSD$");
 #include <dev/ofw/ofw_bus.h>
 #include <dev/ofw/ofw_bus_subr.h>
 
-#include <dev/pwm/pwmbus.h>
-
-#include "pwmbus_if.h"
+#include <dev/pwm/ofw_pwm.h>
 
 int
 pwm_get_by_ofw_propidx(device_t consumer, phandle_t node,

Copied and modified: head/sys/dev/pwm/ofw_pwm.h (from r349114, head/sys/dev/pwm/pwmbus.h)
==============================================================================
--- head/sys/dev/pwm/pwmbus.h	Sun Jun 16 15:34:10 2019	(r349114, copy source)
+++ head/sys/dev/pwm/ofw_pwm.h	Sun Jun 16 15:56:59 2019	(r349115)
@@ -28,7 +28,8 @@
  * $FreeBSD$
  */
 
-#ifndef _PWMBUS_H_
+#ifndef _OFW_PWM_H_
+#define _OFW_PWM_H_
 
 #include <dev/ofw/openfirm.h>
 
@@ -51,4 +52,4 @@ int pwm_get_by_ofw_property(device_t consumer, phandle
 int pwm_get_by_ofw_name(device_t consumer, phandle_t node, const char *name,
     pwm_channel_t *out_channel);
 
-#endif /* _PWMBUS_H_ */
+#endif /* _OFW_PWM_H_ */

Modified: head/sys/dev/pwm/pwmbus.c
==============================================================================
--- head/sys/dev/pwm/pwmbus.c	Sun Jun 16 15:34:10 2019	(r349114)
+++ head/sys/dev/pwm/pwmbus.c	Sun Jun 16 15:56:59 2019	(r349115)
@@ -41,8 +41,6 @@ __FBSDID("$FreeBSD$");
 
 #include <machine/bus.h>
 
-#include <dev/pwm/pwmbus.h>
-
 #include "pwmbus_if.h"
 
 struct pwmbus_channel_data {


More information about the svn-src-head mailing list